1

How can I set the umask for the Apache user to have files default to -rwxrwx--- ?

I have an application that wants one directory to have either 0750 or 0770 permissions, which is great if it’s local, but if I try mount the directory on a CIFS share, chmod has no effect on the directory mount point permissions.

I’ve read that if the umask is set differently, it will mount properly - just am unsure how to do that.

  • 1
    You will need to set the umask for whatever software is running as the apache user (presumably Apache httpd, or something running thereunder?). Adding Windows sharing protocols compounds the troubles. – thrig Oct 23 '17 at 2:10
  • @thrig - the share I have available is presented as CIFS (by a *nix box somewhere) - NFS is not an option here – warren Oct 23 '17 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.