0

I have got a new internet connection which is at 50Mbps. The previous one was at 6M. I have this problem now where i can't get more than around 15M. My wifi card is the RTL8187 onboard of the "asus p5k premium wifi", which according to specification says it supports 54M. I have installed the driver through the package "firmware-realtek". I use Debian with KDE.

When i run iwconfig i get:

wlx0015af3e89a2 IEEE 802.11 ESSID:"Digicom -Inva"
Mode:Managed Frequency:2.432 GHz Access Point: C8:3A:35:B0:4D:F0
Bit Rate=9 Mb/s Tx-Power=20 dBm
Retry short limit:7 RTS thr:off Fragment thr:off Encryption key:off Power Management:off Link Quality=70/70 Signal level=-6 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:0 Invalid misc:67 Missed beacon:0

It says 9Mbps even though i get around 15. On a laptop it says 144Mbps and i get good speed with the same connection. So i figure it must be my wireless card at fault but when i try to increase it,

sudo iwconfig wlx0015af3e89a2 rate 54M

It does nothing and remains the same

sudo iwconfig wlx0015af3e89a2 commit

Error for wireless request "Commit changes" (8B00) : SET failed on device wlx0015af3e89a2 ; Operation not supported.

iw dev wlx0015af3e89a2 link

Connected to c8:3a:35:b0:4d:f0 (on wlx0015af3e89a2)

SSID: Digicom -Inva

freq: 2432

RX: 97569354 bytes (126526 packets)

TX: 26187443 bytes (56838 packets)

signal: -6 dBm

tx bitrate: 54.0 MBit/s

bss flags: short-slot-time dtim period: 1 beacon int: 100

Is there anything i can do to max it out?

One more thing, i dont know if this means anything, but i was unable to connect to this network using /etc/network/interfaces, as i was connecting to my previous modem. I resorted to using wicd (the only thing that worked) because plasma-nm was not working either.

source /etc/network/interfaces.d/*

auto lo iface lo inet loopback

auto wlx0015af3e89a2

iface wlx0015af3e89a2 inet dhcp

wpa-ssid Digicom-Inva

wpa-psk ***

# this below works fine

#wpa-ssid othermodem

#wpa-psk ***

Thank you

2

The wifi general slowness can be due to many factors; besides the 2.4 GHz band being saturated in many parts of the word, realtek stinks, get another brand and get a 5GHz capable AP.

You can try to move over to a less congested channel, but alas, in residential areas, often the overall 2.4GHz spectrum is so populated that the gains will be minimal.

The speed also is automatically selected depending on the quality/usage of the channel, antenna characteristics, distance from the AP and walls e.g. you will have a worse performance trying to force a higher speed. On top of that, most of the ISP issued APs are very poor on hw specs.

Those are not Unix problems actually.

For getting a broad insight in realtek problems, please see this related thread. Wi-Fi problems using ASUS USB-N13 adapter

As pointed out in the thread and links, some workarounds can be tried at driver level for realtek wifi chipsets. The workarounds are unreliable at best and do not improve much the stability of braindead hardware defective by design over time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.