I am trying to disable my laptop internal keyboard, because I want to use my USB external keyboard placing it above the laptop keyboard.

I am using GRUB to dual-boot Linux and Windows. I could disable the internal keyboard after booting, both Linux(via xinput) and Windows(via installing wrong driver for the internal keyboard).

But when selecting OS in GRUB, the laptop keyboard works normally. What should I do in order to disable the laptop internal keyboard in GRUB?

p.s. I don't want to physically remove the laptop keyboard like disconnecting it from motherboard.

  • Did you checked your BIOS settings first? You may be able to disable either the internal keyboard device itself or the internal port it is attached to from there. – WhiteWinterWolf Oct 22 '17 at 11:55
  • @WhiteWinterWolf I don't see any internal device/port setting in my BIOS. – suhdonghwi Oct 22 '17 at 12:07
  • Well, I don't want to be pessimistic, but it seems that someone already asked a similar question there without any easy answer... good luck! – WhiteWinterWolf Oct 22 '17 at 12:23
  • @WhiteWinterWolf Oh, thanks for the information. Maybe I should do more research. – suhdonghwi Oct 22 '17 at 14:28
  • This may be a bit brutal, bit you could physically unscrew the back of your laptop and disconnect the keyboard (or just cut the connection). – anonymous Oct 23 '17 at 20:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.