2

It's possible that part of my issue is that I don't know the correct names for parts of the gnome desktop, so it's impacting my google-fu. I've got a couple of screenshots. If I start with a standard window like this, the title bar is visible. standard window

If I maximize the window, the title bar disappears, but the title bar information is now in the bar across the top of the screen. maximized window

However, if I snap the window to the left (or right) side of the screen, the title bar disappears, but the information does not show up across the stop of the screen. snapped window

I was on Fedora 25 when I first noticed this issue. I've upgraded to Fedora 27 beta and it's still there. I'm using GNOME Version 3.26.1 which I believe is the latest available version.

As I said, I tried to google this issue and even searched stackexchange, but haven't seen an answer. I'm not sure if it's a setting I inadvertently changed, a bug or expected behavior.

Hopefully someone can provide more information about this.

3
  • You want a MacOS like behavior?
    – jdwolf
    Oct 22, 2017 at 14:53
  • @pomsky it was Pixel Saver. Thanks for the pointer. That turned the feature off entirely, but at least it's consistent now. If you want to put that as an answer, I'll give you credit. Oct 22, 2017 at 17:51
  • @jdwolf possibly, I'm not sure what MacOS behavior is like when it comes to the title bar. pomsky nailed what was causing the issue, if I get board I might try to dig into Pixel Saver some. Oct 22, 2017 at 17:55

1 Answer 1

2

It seems you have at least one of the following GNOME shell extensions activated:

  • Pixel Saver
  • No Title Bar

Check in the list of your installed extensions and deactivate the one(s) accordingly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .