1

NetworkManager - WiFi connection breaks soon after connecting

Hey,

Question and problem description:

Until yesterday, my home WiFi works perfectly. And now, very soon (seconds to minutes) after establishing the WiFi connection, I loose the network (ping: sendmsg: Network is unreachable).

To be more precise, when booting my laptop and automatically logging into my WiFi I can establish a connection. I also can use access the Web via Chrome/Firefox for a little time.

This is ping's output:

user@laptop ~ $ ping www.google.at
PING www.google.at (216.58.213.195) 56(84) bytes of data.
64 bytes from ham02s15-in-f195.1e100.net (216.58.213.195): icmp_seq=1 ttl=52 time=45.7 ms
64 bytes from ham02s15-in-f195.1e100.net (216.58.213.195): icmp_seq=2 ttl=52 time=35.3 ms
64 bytes from ham02s15-in-f195.1e100.net (216.58.213.195): icmp_seq=3 ttl=52 time=34.0 ms

After several seconds the latency is getting very high ...

64 bytes from ham02s15-in-f195.1e100.net (216.58.213.195): icmp_seq=40 ttl=52 time=794 ms
64 bytes from ham02s15-in-f195.1e100.net (216.58.213.195): icmp_seq=41 ttl=52 time=804 ms

... and ping's output changes to

ping: sendmsg: Network is unreachable 
ping: sendmsg: Network is unreachable

My home's WiFi works also fine on smartphones as well as using the a direct connection to the router via a ethernet cable.

What had probably changed?

Yesterday I logged in to a for my laptop unknown WiFi (my university's one) and since then my home's WiFi has the problem I described before. I guess that, by using the external WiFi some NetworkManager setting had changed?

My setup

  1. Linux Mint 17
  2. NetworkManager 0.9.8.8
  3. Laptop HP625

Additional infos

ifconfig's output for my wifi

wlan0     Link encap:Ethernet  HWaddr e0:2a:82:a0:8e:1f  
          inet addr:192.168.0.13  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::e22a:82ff:fea0:8e1f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:13281 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12084 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:14711000 (14.7 MB)  TX bytes:2746665 (2.7 MB)

Thanks in advance for any help, Jürgen

  • Have you tired with some other device? Maybe your phone with university's wifi and home wifi – Arpit Agarwal Oct 21 '17 at 11:44
1

Problem solved!

I deleted the content of the following directory

/etc/NetworkManager/system-connections

rebooted, and than logged into my home's WiFi once more, and then it worked!

What exactly the problem was, I don't know. It's a little bit weird, that it now worked, because I had deleted all the properties of the home's WiFi as well as the one of the university's (previously unknown to my laptop) WiFi via the NetworkManager-GUI.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.