Trying to ping my router or any server results in: Network is unreachable

I have installed Kali 2017.2 on a virtual machine using VMware WS14 on a Windows 7 machine. The host is connected with an Ethernet cable to the router.

I ran some basic commands:

# vi /etc/resolv.conf
domain localdomain

# vi /etc/network/interfaces
auto lo
iface lo inet loopback
iface eth0 inet dhcp

# netstat -nr returns an empty routing table

Network Adapter is NAT

  • It would be great if some points to be provided before the negative vote
    – Dante
    Commented Oct 21, 2017 at 9:34
  • I'm not the downvoter, but you say you are a newbie, and Kali Linux is not recommended for newbies. It's not a general purpose distribution.
    – Sparhawk
    Commented Oct 22, 2017 at 11:10
  • Well you got to start from somewhere, right? anyway I already used Ubuntu, Raspbian on my Raspberry pi but I still consider myself a noob.
    – Dante
    Commented Oct 22, 2017 at 18:02
  • I'm sorry but why my question is on hold? I think my description was very clear, I was unable to ping any computer/server/machine, it always resulted in 'Network is unreachable' error.
    – Dante
    Commented Oct 22, 2017 at 18:04
  • Kali is not the place to start. Even if you were proficient at other kinds of Linux, it's still only recommended for "professional penetration testers and security specialists". The question was put on hold because it's not detailed enough. There is not enough information for us to answer it. You might add more information if you would like it to be reopened, but since you already have the answer, it's probably not worth your time.
    – Sparhawk
    Commented Oct 22, 2017 at 22:29

1 Answer 1


After a night of struggling with this issue, I found that I had to change the Network Adapter from NAT to Bridged and it worked!

  • Did work for me ! I tried the configurations possible NAT , Bridged, Custom . . . still have the same problem Commented Sep 3, 2019 at 12:03

Not the answer you're looking for? Browse other questions tagged .