1

My problem is the following. My system is detecting my USB 3.1 Gen1 hub (onboard hub).

First, I confirmed that my motherboard does indeed have support for USB 3.1. I have an Asus H97-PRO which has obviously the H97 chipset which does have support for USB 3.1 Gen1. You can find listed in the Asus the following 6 x USB 3.1 Gen 1 port(s) (4 at back panel, blue, 2 at mid-board). So, my board does have support for USB 3.1 Gen1`.

If I do lsusb, I get two USB 2.0 hubs. I have one USB 2.0 hub and one USB 3.1 Gen1 hub.

Bus 002 Device 004: ID 04d9:a070 Holtek Semiconductor, Inc. 
Bus 002 Device 002: ID 8087:8001 Intel Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8009 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

If I do lsusb -t. I get the two hubs with a speed of 480M as expected.

/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/2p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/8p, 480M
        |__ Port 4: Dev 4, If 0, Class=Human Interface Device, Driver=usbhid, 12M
        |__ Port 4: Dev 4, If 1, Class=Human Interface Device, Driver=usbhid, 12M
        |__ Port 4: Dev 4, If 2, Class=Human Interface Device, Driver=usbhid, 12M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/2p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/6p, 480M

Using one of my development boards, which has USB 3.0, I can confirm that when connected to a USB 3.1 port, it is forced to run on USB 2.0.

I have already ran update-usbids, update-pciids and added iommu=soft to GRUB_CMDLINE_LINUX_DEFAULT in the grub configuration.

I've ran out of ideas. Thanks in advance for everyone who tries to help.

  • 3
    Before anyone else asks, the lsusb -t output does indeed confirm that the kernel only sees USB 2 ports: USB 3 ports would appear as Class=root_hub, Driver=xhci_hcd/6p, 5000M (with a varying number of ports of course, the important part here is “5000M”). – Stephen Kitt Oct 20 '17 at 19:37
  • I just answered the question. For some reason the motherboard didn't came with XHCI enabled by default which I took for granted. Guess we can't trust in the manufacturers. – FFY00 Oct 20 '17 at 19:44
3

Okay, for some reason my motherboard doesn't come with the XHCI support enabled by default. So if anyone is experiencing a similar issue just go and check if XHCI is enabled in the bios.

  • 1
    The Intel H97 chipset was released in 2014, when Windows 10 was not yet released and it was still important that installations of Windows 7 (with no built-in USB 3 support in the installer) were as seamless as possible. If the system was set by default to legacy mode, you could install the OS, install the USB 3 drivers and then enable USB 3 with fuss. But if the system was set to prefer USB 3 instead, the user would have to be careful to plug the keyboard and mouse into USB2-only ports for the installation, or there would have been no way to interact with the USB3-unaware OS installer. – telcoM Jan 13 at 15:05
0

xHCI is responsible for working of USB 3 port, whereas EHCI driver lets USB 2 work.

On dual-boot between Windows 10 and Linux Ubuntu 18.04, setting the xHCI to disabled allows the dual boot to function correctly on BIOS under EHCI controller.  As a result, a USB 3 port acts as a USB 2 port.

  • If you’re quoting something, identify the source.   If you aren’t quoting, don’t use quote formatting. – G-Man Jan 13 at 23:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.