2

For example output of same command

rsync -auzn --stats

for version 3.1.2 :

Number of files: 51 (reg: 39, dir: 12) Number of created files: 30 (reg: 30) Number of regular files transferred: 30 Total file size: 771,209,382 bytes Total transferred file size: 746,913,131 bytes Literal data: 0 bytes Matched data: 0 bytes File list size: 995 File list generation time: 0.001 seconds File list transfer time: 0.000 seconds Total bytes sent: 197 Total bytes received: 1,189 sent 197 bytes received 1,189 bytes 924.00 bytes/sec total size is 771,209,382 speedup is 556,428.13 (DRY RUN)

for version 3.0.7 :

Number of files: 51 Number of files transferred: 30 Total file size: 771209382 bytes Total transferred file size: 746913131 bytes Literal data: 0 bytes Matched data: 0 bytes File list size: 959 File list generation time: 0.001 seconds File list transfer time: 0.000 seconds Total bytes sent: 197 Total bytes received: 1189 sent 197 bytes received 1189 bytes 554.40 bytes/sec total size is 771209382 speedup is 556428.13 (DRY RUN)

These changes cause errors in shell scripts using rsync. Does anybody know is there any way to make it work (output of --stats) in old-fashion?

1 Answer 1

0

Default number output format has changed in rsync version 3.1.0:

Output numbers in 3-digit groups by default (e.g. 1,234,567). See the --human-readable option for a way to turn it off. See also the daemon's log format parameter and related command-line options (including --out-format) for a modifier that can be used to request digit-grouping or human-readable output in log escapes. (Note that log output is unchanged by default.)

According to rsync(1), human readable format can be disabled with --no-human-readable (--no-h) command line option.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .