I use GNU/Linux Mint 18.2 (based on Ubuntu 16.04). Very recently, I've started seeing the following error message, repeated many times, when I start some GUI apps (e.g. meld):

unable to create file '/run/user/1000/dconf/user': Permission denied.  dconf will not work properly.

Now, I'm able to work around this by manually changing the ownership of /run/user/1000/dconf/user, but that's kind of a lame hack and certainly not robust.

Why have I been seeing this error and what's the "right way" to avoid it (if any)?

  • 1
    I think it's caused by running certain GUI programs as superser: I get this same problem when running ktsu to open a terminal app (called terminator) as a root window. Apparently terminator is using my UID instead of root's in /run/user/UID/user, and that can change the owner of the file to root causing "permission denied" when I run terminator as myself.
    – frayser
    Sep 6, 2018 at 0:35

3 Answers 3


chown 1000:1000 /run/user/1000/dconf/user

  • 4
    But will this not revert to the incorrect permissions later? e.g. by being recreated?
    – einpoklum
    Mar 28, 2019 at 12:02

The issue can be caused by running a GUI after changing user using su command. Certain environmental variables are not changed causing the error. See


Try running the program by logging in as that user directly.

# rmdconfuser - remove dconf user

if [ -e "/run/user/1000/dconf/user" ] 
    rm -f /run/user/1000/dconf/user

# Uncomment the next line if mate-settings-daemon is eating up too much memory
# killall -9 mate-settings-daemon

then execute chmod +x rmdconfuser and place rmdconfuser into your ~/bin/ or /usr/local/bin as root and sudo rmdconfuser to stop the problem. You can also make rmdconfuser set its own uid to root, so you can run it without being root yourself.

Unfortunatelly this is only a work around. The problem may appear again & again.

  • Interesting user name you have there. Why would I have the mate-settings-daemon running, though?
    – einpoklum
    Oct 21, 2017 at 10:54
  • sorry - because it caused the problem of eating the ram on my machine running mate on mint. If you have no mate then simply forget the last line. Oct 21, 2017 at 14:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .