When making a backup to a VeraCrypt encrypted container, my PC got to a point when it was unusable - every few seconds freezes for several seconds, sometimes "only" applications are unresponsive, other times everything is frozen and not even mouse can be moved, input from keyboard is swapped (e.g. I type "abc" and got "bac").

It does not do this when I am backing up to a network drive (Samba) or copying to another drive (those are encrypted as well, but not by VeraCrypt).

I am using SimpleBackup, VeraCrypt and an USB HDD.

Worst part is that I needed to use PC at the time and I was unable to safely stop this. Killing SimpleBackup didn't help, force unmount of container didn't work (it was unmounted, yet still writing), unmount from VeraCrypt wasn't possible (device in use or some error like that) and disconnecting USB via icon in tray wasn't doing anything either. I had to unplug USB cable to stop this freeze-fest.

Any idea what is causing this and how to fix it? I thought that IO should never freeze whole desktop/PC. Possibly only badly written applications which are using blocking access in UI thread, and they should only freeze themselves.

I am using Kubuntu LTS 16.04.3, with the official repository kernel (Linux pc1 4.4.0-97-generic #120-Ubuntu SMP Tue Sep 19 17:28:18 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux). It was not swapping. CPU usage was very high - like 90% (at least according to a widget in a tray).

It's VeraCrypt version 1.18. The USB HDD is WD Elements 1TB.

  • I think I have everything from official repo. uname -a prints Linux pc1 4.4.0-97-generic #120-Ubuntu SMP Tue Sep 19 17:28:18 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux. VeraCrypt in about dialog says 1.18. USB HDD is WD Elements 1TB. – monnef Oct 20 '17 at 9:25
  • Could the USB HD be the issue? google link – jc__ Oct 20 '17 at 13:28
  • @roaima Oh, you're right. Added. – monnef Oct 20 '17 at 14:16
  • @jc__ I tried unix.stackexchange.com/a/107722/198276, but while it solves lags and freezes, it also makes IO related to external HDD unbelievably slow. A task previously done in like one hour is now running over 2h and is barely half way done. It's far from being a solution, because it replaces one problem with another. :( – monnef Oct 20 '17 at 16:58
  • I've seen the same thing with a USB pendrive, only plugged directly into a USB port. But going through a USB hub it worked fine... Try the same USB drive with the same port, but no encryption, could narrow the problem down. – Xen2050 Oct 27 '17 at 16:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.