2

xinput set-prop 13 298 0 1

I want to run this command automatically in order to disable mouse acceleration. This was easily done in various ways on Debian 8, but everything has changed in Stretch, and I've tried everything I can think of.

This command needs to run after X has started up. (So, not when booting, but on login.)

Or if someone knows of a more permanent way to completely disable mouse acceleration in Debian 9? (Most likely making use of libinput?) Either way, I appreciate any input. Thanks!

Update: For a DE, I am using the default X11 Debian Desktop Environment.

  • Which DE are you using? Most DEs have some way of setting startup applications (which can include scripts). – Mountainerd Oct 20 '17 at 5:07
3

If you are still using X and not Wayland, then the options are

1) edit xorg.conf with a proper section for your device to set the property. Details depend on the device.

2) configure your display manager (xdm, kdm, gdm, lightdm, whatever) to run this after the X server starts, details depend on the display manager used.

3) Make sure your display manager runs .xsession or a similar file on startup, execute command there.

You also shouldn't use xinput with hard-coded numeric ids; the numbers are not guaranteed to be the same across boots or server restarts.

If the property is one of the mouse acceleration properties (no way to guess with the numbers), I'd recommend to read man xorg.conf, section Pointer Acceleration, and set those you want in your xorg.conf (choice 1).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.