3

So I have the third party nvidia graphics drivers up to date for my machine, and the HDMI port on my graphics card works fine.

There is a secondary HDMI port on my machine but it is not working. It works fine on windows, and it even turns on briefly while Ubuntu boots, but other than that it does not work on Ubuntu.

xrandr does not detect it, I've entered the system settings gui and tried detect display but nothing happens. I have installed the ubuntu-common drivers package, the nvidia-common drivers package and the latest nvidia graphics drivers. I'm not sure what else I need, but I'm sure it's some driver issue because it works on windows so I know the hardware is fine.

2
  • Sometimes my Ubuntu doesn't detect HDMI presence. Shutting down (not just a reboot) always fixed the issue. Try this or this. Add the output of sudo lshw -C display and xrandr -q.
    – Pablo A
    Aug 6 '18 at 6:02
  • My Mint 19.3 does not detect HDMI only if I log off and log in again. Mar 12 '20 at 11:09
-1

The physical connector is managed by AMD, and NVIDIA controls the output. To check whether this is your problem run: glxinfo | egrep "OpenGL vendor|OpenGL renderer"

My output was similar to this:

enter image description here

Then, I edited my xorg.conf files to fix the issue and designate NVIDIA as primary driver:

First, remember to make backups of your delicate files:

sudo cp -p /usr/share/X11/xorg.conf.d/10-nvidia.conf /usr/share/X11/xorg.conf.d/10-nvidia.conf

sudo cp -p /usr/share/X11/xorg.conf.d/10-amdgpu.conf /usr/share/X11/xorg.conf.d/10-amdgpu.conf.backup

Then, edit your files. Open 10-nvidia.conf and Option "PrimaryGPU" "yes" before the EndSection line so it looks like this:

enter image description here

Next, open the file 10-amdgpu.config and replace the line Driver "amdgpu" with Driver "modesetting"

Save everything, reboot yur system and the outputs should work fine now!

Test which one is your default HMMI driver:

glxinfo | egrep "OpenGL vendor|OpenGL renderer"

enter image description here

Based on: https://9to5linux.com/how-to-connect-your-laptop-to-an-external-monitor-on-linux-fix-for-hdmi-no-signal-issue

5
  • You seem to have taken screenshots from an external blog and posted them as your own here (and here). You have also posted this exact answer on two separate question. Here, you could have posted the first paragraph as a question in a comment, because the rest depends on the user's answer to that inquiry.
    – Kusalananda
    Apr 26 '21 at 8:41
  • I took my time to help, an unanswered (actually many people wanted a solution over many places) question, with no solution over 3 years. You could have just mentioned, not making my effort useless by downvoting. Or you could have edited it, if you want the community to benefit, of course ;) Apr 26 '21 at 17:57
  • Do you know what license those screenshots are under and how you now have relicensed them? Do not post contents here that you don't have permission to share.
    – Kusalananda
    Apr 26 '21 at 18:09
  • CC BY-SA sharealike Apr 26 '21 at 18:12
  • That's what it is now, yes.
    – Kusalananda
    Apr 26 '21 at 18:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.