1

When I tried to logged-in on gnome shell, it will just goes black then after a few seconds it will just comeback to GDM.

I am using fedora 26.

Any advice how I can fix this? thanks.

Edit:(requested on the first comment)

I don't know if it caused by the update, but I did an update before it was happened. This morning I run an update then a moment later shutdown the computer, when I came home tried to login and this was happened.

Also I don't know what to look at the logs. and I cant find any xsessions-erros file on my home directory.

Actually I am logged in the same machine but using the my test Awesome WM user.

Edit: BTW I can logged-in on gnome on Xorg.

  • Please edit your question and give us some information we can use. We don't have access to your machine after all. Did this happen suddenly? After an update? Are there any errors in the log files? Can you log in from the command line? Anything relevant in ~/xsession-errors? Have you ever managed to login successfully on this machine? – terdon Oct 19 '17 at 13:35
  • What happens if you pick the X11 session instead of the default GNOME on Wayland? – mattdm Oct 20 '17 at 3:30
  • @mattdm Is X11 and Xorg the same? I cant find X11 in the GDM. If they are the same, the only thing I noticed is that my cursor theme is not working. I am using La Capitaine. – zer09 Oct 20 '17 at 5:02
  • @zer09 Same, yes. – mattdm Oct 20 '17 at 12:26
1

The cause why Wayland kicking me back to GDM, is because of the La Capitaine cursor theme.

When I tried to change the cursor to Adwaita(default) when I am still in Xorg, then logged-out and logged-in back to Wayland I can logged in back successfully. But as soon I change the cursor theme to La Capitaine Wayland kick me out to GDM.

BTW the La Capitaine Icon theme is still working without a glitch.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.