0

I encountered an issue where my Ubuntu 17.04 VM would enter maintenance mode on every boot. However, if I pressed Ctrl-D, or exited the maintenance shell and continued the boot, the system would start up fine, with no failed jobs.

I eventually narrowed it down to a my 9pfs Virtual filesystem mount. The job was hanging for no discernible reason. Running it manually from the maintenance mode would succeed. Enabling debugging for SystemD didn't produce any more helpful errors.

1

The solution is to edit the /etc/fstab mount options for the 9pfs mount, and append noauto,x-systemd.automount. This will delay mounting long enough to avoid whatever race condition causes the error.

Example fstab entry

4tb /mnt/4tb 9p trans=virtio,rw,noauto,x-systemd.automount 0 0

https://forums.freenas.org/index.php?threads/9p-mounts-in-linux-vm-fail-at-boot-but-succeed-moments-later.52413/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.