2

I am trying to setup the TL-WN722N connection over Ubuntu running in a Virtual Box. The later idea is to interface TL-WN722N with a cyclone V SoC running a lightweight Linux - Angstrom.

Right now, I have followed the steps/suggestions provided here:

How can I get my wifi card TP-Link TL-WN722N to work in Kali-Linux Oracle VM Virtual Box?

However, I could not get it working. I used modprobe ath9k to load the module manually because dmesg | grep -e wlan -e ath9k returned nothing. I could see the modules now using lsmod

Module                  Size  Used by
ath9k                 147456  0
ath9k_common           36864  1 ath9k
ath9k_hw              466944  2 ath9k,ath9k_common
ath                    28672  3 ath9k_hw,ath9k,ath9k_common
mac80211              782336  1 ath9k

lsusb returns the following :

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 80ee:0021 VirtualBox USB Tablet
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

and finally iwconfig

lo        no wireless extensions.

enp0s3    no wireless extensions.

I have also tried adding filter using the Virtual Box option. When the atheros option is selected using Devices -> USB -> Settings : the following error is encountered :

Failed to attach the USB device ATHEROS USB2.0 WLAN [0108] to the virtual machine ubuntu_max.

USB device 'ATHEROS USB2.0 WLAN' with UUID {4a33886b-da96-4ef0-86f6-14e41c4326e5} is busy with a previous request. Please try again later.

Result Code: E_INVALIDARG (0x80070057)
Component: HostUSBDeviceWrap
Interface: IHostUSBDevice {c19073dd-cc7b-431b-98b2-951fda8eab89}
Callee: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Does anyone have a hand on this issue? The solution in the existing link does not really seem to help my issue here.

Details :

i) Host OS : Windows 7 Professional Guest OS : Ubuntu 16.04

ii) the host machine recognizes the device. I can also see the device in the Virtual box devices list. Screenshot of the device recognized by Virtual Box

Clicking on the device name results into error as mentioned :

Failed to attach the USB device ATHEROS USB2.0 WLAN [0108] to the virtual machine ubuntu_max.

USB device 'ATHEROS USB2.0 WLAN' with UUID {4a33886b-da96-4ef0-86f6-14e41c4326e5} is busy with a previous request. Please try again later.

Result Code: E_INVALIDARG (0x80070057)
Component: HostUSBDeviceWrap
Interface: IHostUSBDevice {c19073dd-cc7b-431b-98b2-951fda8eab89}
Callee: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

iii) Setup for the card was tried in the following ways :

  • suggesstions as per the link mentioned in the question that required installing extension packages for the VirtualBox and enabling USB 2.0.

  • installing drivers for atheros-firmware

  • adding filter using the Virtualbox option .

  • Please edit your question and i) clarify what OS the host machine is running and what version of Ubuntu you have in the guest; ii) explain if the card is correctly recognized by the host; iii) explain how you set up the card for the virtual machine. – terdon Oct 16 '17 at 12:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.