0

I wanted to try out oss because sound on alsa is not great. I am on elementaryOS Loki which is built on ubuntu.

Anyways I installed alsa-oss using sudo apt-get install alsa-oss but it didn't recognize my sound card(its Realtek ac290). So I uninstalled it and now I dont have any sound. I have tried reinstalling alsa using

 sudo aptitude --purge reinstall linux-sound-base alsa-base alsa-utils linux-image-`uname -r` linux-ubuntu-modules-`uname -r` libasound2

but this doesnt fix anything, still no sound. When I type alsamixer in terminal I get :cannot open mixer: No such file or directory Please help!

0
sudo apt-get install --reinstall linux-image-extra-$(uname -r)

This command reinstalled all the missing drivers and fixed the problem. I will just leave it here so that it can help others in future.

Source: https://askubuntu.com/questions/940091/ubuntu-16-04-reinstall-all-drivers

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.