0

Recently got a laptop, and now have it dual-booting Slackware 14.2x64 (along with its pre-installed win10). And have wifi configured, apparently working okay, with an old linksys wrt120n. But every two hours or so (or maybe exactly every two hours), wifi drops and I have to reboot.

Pointing my browser to the wrt120n's local setup page, I found under wireless security, "Key renewal 7200seconds". I tried setting that field to 99999, but it then complains "The value is out of range [600-7200]". That's with "Security mode: WPA2 Personal" which I'd prefer not to change.

Is there any way around that key renewal? I haven't been able find any dhcpcd options for that (I'm running dhcpcd -d -h psi9star -s 192.168.1.9 wlan0 now). Or is that key renewal maybe not the problem at all? Whatever the problem, booting win10 seems to run okay past that time limit.

>>Edit<<
Thanks GAD3R. I'm editing to provide your requested info (in comments below), and some other info that subsequently emerged ...

...requested info
(note: this is a "vanilla" install of slackware 14.2x64, plus multilib for 32-bit support, on a gpt/uefi partition; no "customizations")

uname -a
  Linux psi9star 4.4.14 #2 SMP Fri Jun 24 13:38:27 CDT 2016 x86_64
  Intel(R) Core(TM) i7-7500U CPU @ 2.70GHz GenuineIntel GNU/Linux
lspci -knn | grep Net -A2
  02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd.
  RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
  Subsystem: Hewlett-Packard Company RTL8723BE PCIe
  Wireless Network Adapter [103c:81c1]
    Kernel driver in use: rtl8723be
    Kernel modules: rtl8723be

...other info

I probably should have earlier noticed that dmesg has some 2K lines of errors, all like the few reproduced below, and all involving (retries, I guess, of) the same device,

[  543.758835] pcieport 0000:00:1c.5:    [ 0] Receiver Error         (First)
[  543.758848] pcieport 0000:00:1c.5: AER: Corrected error received: id=00e5
[  543.759540] pcieport 0000:00:1c.5: can't find device of ID00e5
[  543.759548] pcieport 0000:00:1c.5: AER: Corrected error received: id=00e5
[  543.759563] pcieport 0000:00:1c.5: PCIe Bus Error: severity=Corrected,
               type=Physical Layer, id=00e5(Receiver ID)
[  543.759570] pcieport 0000:00:1c.5:   device [8086:9d15]
               error status/mask=00000001/00002000

That device is apparently a pci bridge (below are the only two using the pcieport driver),

lspci -knn
  00:1c.0 PCI bridge [0604]: Intel Corporation Device [8086:9d14] (rev f1)
        Kernel driver in use: pcieport
        Kernel modules: shpchp
  00:1c.5 PCI bridge [0604]: Intel Corporation Device [8086:9d15] (rev f1)
        Kernel driver in use: pcieport
        Kernel modules: shpchp

But I'm not seeing how this would be related to the wifi problem (though I could be wrong about that). In any event, win10 continues to maintain wifi connections without problems.

  >>Edit/Answer<<
___________________

GAD3R solved the problem in his comment below, which is elaborated in his answer to another question, Problems with the Wifi connections (RTL8723BE). Kali Linux where it turns out that the rtl8723be kernel module (and maybe some of the other realtek/rtlwifi modules) aren't working properly on kernel distributions prior to 4.7, or thereabouts. Definitely not working properly with my 4.4.14 kernel, but I'm not sure when it may have been fixed.

Anyway, if you're running one of these not-so-recent kernels and using (or unsuccessfully trying to use) realtek wifi, then do see GAD3R's answer to Problems with the Wifi connections (RTL8723BE). Kali Linux and download the corrected realtek_wifi kernel modules from github https://github.com/lwfinger/rtlwifi_new/ as GAD3R suggests.

  • 1
    The problem come from the router firmware , i found this article on linksys community.linksys.com/t5/Wireless-Routers/… Disabling the SPI firwall protection should solve the problem for some users – GAD3R Oct 15 '17 at 16:44
  • Thanks @GAD3R Sounded promising, but when I checked "SPI firewall" was already disabled (and all its router functions are disabled -- I'm just using it as a WAP). And win10 seems to be running okay (but who would want to run windows?:). I've got an iptables firewall running under slackware. But thanks a lot for that linksys.com link -- I hadn't found that stuff while googling before posting this question (I did find lots of stuff about dropped wifi connections, but nothing that seemed to be applicable, or to solve the problem when possibly applicable) – John Forkosh Oct 15 '17 at 23:47
  • 1
    To troubleshooting the problem you need to new some information about the wifi card : lspci -knn | grep Net -A2 and the kernel version uname -a , you can edit here – GAD3R Oct 16 '17 at 6:32
  • @GAD3R Thanks again. Requested info added above. – John Forkosh Oct 18 '17 at 5:21
  • 1
    Try this answer unix.stackexchange.com/a/381264/153195 – GAD3R Oct 18 '17 at 10:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.