3

I realize that Microsoft doesn't even recommend using a windows server as a time service, however I don't have a choice -- closed network in a windows centric shop.

It became an issue when the newer Solaris 11 systems could not sync to the AD servers which come with NTP v4 ( 4.2.8p10 ).

It does work for the Solaris 10 servers using the older v3 (xntpd) as a client. I tried disabling the older client, and enabling the ntp4 client ( 4.2.8p9) on the Solaris 10 systems. So even though it had been working, and uses the same ntp.conf, the v4 client fails to sync.

Anyone have any suggestions on a possible tweak to sync a NTP v4 client to a Windows 2012 R2 AD server?

ntp.conf

server AD_SVR1_IP prefer iburst
server      AD_SVR2_IP
peer        rac-node2

My long term plan is to get the network team to enable a NTP service on one of their device that we all point to.

Thanks

5
  • How far towards "not syncing" do they get? Is NTP traffic allowed there & back? Is the Windows server being excluded for some reason (false ticker, etc)?
    – Jeff Schaller
    Oct 13, 2017 at 20:03
  • They're all in the same subnet and have no firewall between them. Also, no issues in the case when using the v3 client on Solaris 10. The tally code is a space for the two AD servers, as well as any Solaris peers. In the case of the later, the logs indicate that the peer's stratum is too high. Oct 13, 2017 at 20:15
  • ntpq -np AD_SVR1_IP please. And ntpq -np on the Solaris client. Also, what if you remove the prefer keyword?
    – roaima
    Oct 13, 2017 at 20:29
  • Removing prefer has no effect. Oct 13, 2017 at 20:55
  • Issuing cmd against AD servers gives: "timed out, nothing received" But I also see the same error running the command from a Solaris 10 server using the older ntp client. Issuing it against another Solaris server shows what you'd see if you ran ntpq -p on that server. Oct 13, 2017 at 21:07

1 Answer 1

0

This works for me on a Linux-based system running ntpd version 4.2.6p5, talking to a Windows 2012 R2 running as a Domain Controller. (I don't have access to Solaris.)

driftfile /var/lib/ntp/ntp.drift

server AD_SERVER1 iburst
server AD_SERVER2 iburst
server AD_SERVER3 iburst

restrict -4 default kod notrap nomodify nopeer noquery
restrict -6 default kod notrap nomodify nopeer noquery

restrict 127.0.0.1
restrict ::1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.