1

I had second display connected to my laptop before, Google Chrome wants to stay there often. I tried to restore the second display without having the second monitor connected to the laptop (because I wanted to use Google Chrome, Quit does not help). I pressed FN-F9 and then FN-F8 after which I lost the communication to touchpad. Keyboard works fine. I restarted the system many times but still the problem occurs. I do not understand why.

I tried to restore the problem by pressing again the FN keys but no resolution. I want to restore the working touchpad on Wayland Debian.

Lost communication on the touchpad in Wayland now. No touch works. No pressing of the touchpad works.

I can log back to X11 where the touchpad works.

Testing Joshua's proposals

  1. Do gksudo gedit /etc/default/grub, edit GRUB_CMDLINE_LINUX_DEFAULT="quiet i8042.nomux=1 i8042.reset", sudo update-grub successfully and reboot but output still failure with touchpad.

  2. Do gksudo gedit /etc/default/grub, edit GRUB_CMDLINE_LINUX_DEFAULT="i8042.nomux=1 i8042.reset", sudo update-grub successfully and reboot but output still failure with touchpad.

OS: Debian Stretch 9.1
Hardware: Asus Zenbook UX303UA R4028T
Touchpad: FocalTechPS
Window manager: Gnome 3.22 on Wayland 1.12

1

I had an issue similar to that and was able to find a solution on the Arch Wiki. It seems like 4.1 and 4.3 would be good, easy things to try. For me, it was actually adding these kernel options:

i8042.nomux=1 i8042.reset
  • You can do that; whatever you're comfortable with. You'd add the parameters to GRUB_CMDLINE_LINUX_DEFAULT then run sudo update-grub. – Mountainerd Oct 20 '17 at 5:33
  • If that's a copy/paste from your grub config, it may fail with 'queiet' (it should be 'quiet'). – Mountainerd Oct 20 '17 at 5:40
  • update-grub fails or the touchpad still doesn't work after reboot? – Mountainerd Oct 20 '17 at 5:44
  • 1
    I think I have a Zenbook in the office. I'll get Debian up and running and see if I can recreate the issue tomorrow. – Mountainerd Oct 20 '17 at 5:50
  • I haven't been able to recreate the problem you're having yet, no. I've tried, but the behavior simply isn't happening on my end. – Mountainerd Oct 23 '17 at 4:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.