1

On my HP Pavilion laptop I have Linux Mint and Manjaro Linux installed, wheras the former has been installed before the latter.

The problem is that I only have the ubuntu boot loader to choose so I tried creating another boot option via sudo efibootmgr -c -w -l /EFI/Manjaro/grub64.efi -L "Manjaro" because sudo efibootmgr -v did indeed only show the ubuntu option.
After having executed above code I reexecuted sudo efibootmgr -v and this is what it spit out:

Timeout: 0 seconds
BootOrder: 0001,0000,3000,2001,2002,2004
Boot0000* ubuntu        HD(1,GPT,28f41d4a-3c25-4379-8e81-7e4a28a618ca,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)
Boot0001* Manjaro       HD(1,GPT,28f41d4a-3c25-4379-8e81-7e4a28a618ca,0x800,0x100000)/File(\EFI\Manjaro\grub64.efi)
Boot2001* EFI USB Device        RC
Boot2002* EFI DVD/CDROM RC
Boot3000* Internal Hard Disk or Solid State Disk        RC

So I thought I'm good now and I rebooted my computer. However the laptop still booted into the old boot loader and after having booted again I rechecked sudo efibootmgr -v and noticed that my newly created Manjaro option was gone.

So I'm assuming that it got deleted during shutdown or reboot (it persisted a logout) but I have no idea why and how to fix it.
One guess I have is that the boot entry was somehow invalid and therefore got deleted but I just can't see any error when comparing it to the existing (and working) ubuntu option.

So the question is: Does anybody know how to come over this problem?

1

Alright I got it working.

I'm still not sure why the boot option got deleted but running grub-install solved the issue for me as this added the boot option for me.

This might have something to do with the fact that I have (now) two bootloaders installed in parallel. For more infos on this see this question of mine.

0

I had a similar problem where if the entry was named Linux it would get deleted but not other names. Fun times. One thing you can try is to disable the CSM.

  • Actually the legacy mode should be turned off anyways... But I'll check again – Raven Oct 13 '17 at 16:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.