I want to install the latest version of Wine in my Debian box. There is wine_1.4-0.1_i386.deb in the pool/w/wine/ directory in the Debian mirrors. I have added testing, sid repos in the sources.list file. However, the latest wine I can install is always 1.2.3-0.3.

Run apt-cache policy wine shows:

  Installed: (none)
  Candidate: 1.2.3-0.3
  Version table:
     1.2.3-0.3 0
        500 http://mirrors.xxx.com/debian/ testing/main i386 Packages
        500 http://mirrors.xxx.com/debian/ sid/main i386 Packages
     1.0.1-3.1 0
        500 http://mirrors.xxx.com/debian/ squeeze/main i386 Packages
        100 /var/lib/dpkg/status

The existed version 1.4-0.1 doesn't show in any sources.

I have also tried:

sudo apt-get install wine=1.4-0.1

to install the explicit version 1.4-0.1, but still no success.

How to install wine-1.4 by force? Should I download the .deb packages manually and run sudo dpkg -i ...?


Just a small update, wine 1.4 is nowadays available in the sid repository - just run apt-get update and apt-get install wine.

Original answer:

Wine 1.4-0.1 is in the experimental repository. Just add it to your sources.list, run apt-get update and you should be able to install it.

Have a look at How to see package version without install? which shows rmadison to check which suite has which version available.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.