I want to remove this folder : Name Name 1x05 name Formación

I have tried all I have seen on internet :

find -maxdepth 1 -inum INODE_NUMBER -exec rm -i {} \;
rmdir: wrong deleting './Name Name 1x05 name Formación': don't exist file or folder

Too I tried to use mc (Middnight Commander) , Krusader and any other methods I have seen on internet.

But is not posible. Give this problem.

We can enter in folder and to rename parent but we can't rename or delete this folder.

The problem is because is a folder with spaces and wrong chars and is not posible to change it. You can enter on folder but you can't remove or rename.

So is not duplicated. There is not any solution for this case on StackSchange.

I think the only solution would be edit directly inode to make renaming and be able to remove later, but I don't know how to do on Unix system.

System is Ubuntu but I suppose would be in any other system.

Any method to delete this folder or to edit directly folder name ?


  • @Christopher: It is highly unlikely that that will work. – G-Man Says 'Reinstate Monica' Oct 12 '17 at 21:12
  • @Christopher: Yes, it works if having spaces in the file name is the only problem.   The rmdir: wrong deleting './Name Name 1x05 name Formación': don't exist file or folder error message says that the problem is bigger than that. – G-Man Says 'Reinstate Monica' Oct 12 '17 at 21:32
  • @Ricardo: You say “We can enter in folder”.  What do you mean by that?  Obviously you are using the command-line interface; i.e., the shell.  Can you cd into the bad directory?  Can you rename the bad directory?  Do ls -laR from the parent directory and post the output in your question. Do not respond in comments; edit your question to make it clearer and more complete. – G-Man Says 'Reinstate Monica' Oct 12 '17 at 21:38
  • Is this directory mounted on a network share of some description? – Kusalananda Oct 12 '17 at 22:22

I guess the filesystem is corrupted.

If it's a root filesystem you may have to boot to single user mode first, if it's not root filesystem you should stop all the processes that access it and unmount it.

Then figure out what block device it is (e.g. /dev/sdb1 or /dev/mapper/something) and run fsck /dev/that/device.

If you can provide the output of mount (just like that with no parameters) and highlight which mount point contains the affected directory I can come up with a more detailed plan.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.