1

I tried to solve my problem that my touchpad is not running on my Lenovo 720-15IKB by installing the latest rc kernel 4.14.rc5 as described here, which really worked! The touchpad is working then! But now I have a new problem caused by that kernel:

Networking doesn't work correctly with kernel 4.14-rc5

I don't get any IPv4 IP any more in my local Network. IPv6 works correctly. If IPv6 is running in your network, You could add all needed addresses by hand in my /etc/hosts file, but that is no solution ;)

I could only workaround it like this:

Instead of DHCP I used manual wifi configuration which still didn't help at first. Then I connected a USB-LAN adapter once and noticed, that I got a correct internet settings via LAN then. This seems somehow to have fixed some misconfiguration. I can now get correct internet settings via WiFi too. Also after a reboot I can reconnect via WiFi only. But DHCP still doesn't work. I tested this with 3 different WiFis in different places.

I just installed plain standard Ubuntu 17.10 with systemd and Network Manager, no modifications.

How can I get IP4 with DHCP running with the latest kernel?

  • Is the problem with IPv4 or with DHCP? If it works with manually assigned addresses then IPv4 is working just fine. To debug DHCP, which DHCP client are you using? What do the logs say? Are you using network manager, some other helper program, or configuration files? Systemd or no systemd? It's really hard to answer that question without any information ... – dirkt Oct 21 '17 at 22:03
  • I just installed plain standard Ubuntu 17.10 with systemd and Network Manager, no modifications. – rubo77 Oct 22 '17 at 0:31
  • You've replaced the kernel, but what about the wifi drivers? The drivers may need to be recompiled for the new kernel. – RubberStamp Oct 23 '17 at 2:40
1
+50

Looking on google:

https://ubuntuforums.org/showthread.php?t=2372492

https://www.phoronix.com/scan.php?page=news_item&px=AppArmor-Linux-4.14

https://bugs.launchpad.net/ubuntu/+source/apparmor/+bug/1724450

It seems related to AppArmor, and I read there are patches (like perhaps editing apparmor's configuration: apparmor-for-4.14.diff ).

This Ubuntu page on Apparmor gives informations on how to partially disable it. The same command aa-complain can be used to allow both a given command or a whole profile to be bypassed. So first install the required tools (be creative if network isn't working yet...):

apt install apparmor-utils

For dhclient and related binaries (including its communication with NetworkManager), doing this fixes the DHCP issue:

sudo aa-complain /etc/apparmor.d/sbin.dhclient

In case an other unrelated command behaves differently than before and there's no easy profile for it, just using sudo aa-complain /path/to/command should allow it to work unhindered. Keep security considerations in mind.

  • That was it. just: sudo aa-complain /etc/apparmor.d/sbin.dhclient (I had to apt install apparmour-utils) – rubo77 Oct 23 '17 at 18:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.