0

I cant update/upgrade my package on my server because some repository are not accessible.

apt-get update :

Ign:1 https://dl.yarnpkg.com/debian stable InRelease
Ign:2 http://nightly.odoo.com/10.0/nightly/deb ./ InRelease
Err:3 https://dl.yarnpkg.com/debian stable Release

Atteint:4 http://nightly.odoo.com/10.0/nightly/deb ./ Release
Ign:5 http://dl.google.com/linux/mod-pagespeed/deb stable InRelease
Ign:6 https://deb.nodesource.com/node_6.x stretch InRelease
Ign:7 https://download.docker.com/linux/debian stretch InRelease
Ign:8 http://repo.mongodb.org/apt/ubuntu xenial/mongodb-org/3.2 InRelease
Err:9 https://deb.nodesource.com/node_6.x stretch Release

Atteint:10 http://dl.google.com/linux/mod-pagespeed/deb stable Release
Err:11 https://download.docker.com/linux/debian stretch Release

Ign:12 http://debian.mirrors.ovh.net/debian stretch InRelease
Atteint:13 http://repo.mongodb.org/apt/ubuntu xenial/mongodb-org/3.2 Release
Réception de:14 http://debian.mirrors.ovh.net/debian stretch-updates InRelease
Réception de:16 http://debian.mirrors.ovh.net/debian stretch Release [118 kB]
Ign:17 https://packages.gitlab.com/gitlab/gitlab-ce/debian stretch InRelease
Atteint:18 http://security.debian.org/debian-security stretch/updates InRelease
Réception de:20 http://repo.mongodb.org/apt/ubuntu xenial/mongodb-org/3.2 Release.gpg [801 B]
Ign:21 http://download.webmin.com/download/repository sarge InRelease
Ign:22 https://packages.gitlab.com/runner/gitlab-ci-multi-runner/debian stretch InRelease
Err:24 https://packages.gitlab.com/gitlab/gitlab-ce/debian stretch Release

Atteint:25 http://download.webmin.com/download/repository sarge Release
Ign:20 http://repo.mongodb.org/apt/ubuntu xenial/mongodb-org/3.2 Release.gpg
Ign:27 https://artifacts.elastic.co/packages/5.x/apt stable InRelease
Err:28 https://packages.gitlab.com/runner/gitlab-ci-multi-runner/debian stretch Release

Err:29 https://artifacts.elastic.co/packages/5.x/apt stable Release

Ign:30 http://packages.elasticsearch.org/logstashforwarder/debian stable InRelease
Atteint:31 http://packages.elasticsearch.org/logstashforwarder/debian stable Release
Réception de:32 http://packages.elasticsearch.org/logstashforwarder/debian stable Release.gpg [490 B]
Ign:32 http://packages.elasticsearch.org/logstashforwarder/debian stable Release.gpg
Lecture des listes de paquets... Fait
E: The repository 'https://dl.yarnpkg.com/debian stable Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'https://deb.nodesource.com/node_6.x stretch Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'https://download.docker.com/linux/debian stretch Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'https://packages.gitlab.com/gitlab/gitlab-ce/debian stretch Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: Erreur de GPG : http://repo.mongodb.org/apt/ubuntu xenial/mongodb-org/3.2 Release : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY D68FA50FEA312927
W: The repository 'http://repo.mongodb.org/apt/ubuntu xenial/mongodb-org/3.2 Release' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'https://packages.gitlab.com/runner/gitlab-ci-multi-runner/debian stretch Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'https://artifacts.elastic.co/packages/5.x/apt stable Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: Erreur de GPG : http://packages.elasticsearch.org/logstashforwarder/debian stable Release : Les signatures suivantes ne sont pas valables : 46095ACC8548582C1A2699A9D27D666CD88E42B4
W: The repository 'http://packages.elasticsearch.org/logstashforwarder/debian stable Release' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Have already apt-transport-https. Have all GPG public key.

My sources.list file :

deb http://debian.mirrors.ovh.net/debian stretch main
deb-src http://debian.mirrors.ovh.net/debian stretch main

deb http://security.debian.org/debian-security stretch/updates main
deb-src http://security.debian.org/debian-security stretch/updates main

# stretch-updates, previously known as 'volatile'
deb http://debian.mirrors.ovh.net/debian stretch-updates main
deb-src http://debian.mirrors.ovh.net/debian stretch-updates main
deb http://download.webmin.com/download/repository sarge contrib

ls /etc/apt/sources.list.d/

docker.list  elastic-5.x.list  gitlab_gitlab-ce.list  logstashforwarder.list  mod-pagespeed.list  mongodb-org-3.2.list  nodesource.list  odoo.list  runner_gitlab-ci-multi-runner.list  yarn.list

Already try update ca-certificates. No success...

Have no idea for solve this problem :-/

If someone can help, will be nice :)

  • possible duplicate of askubuntu.com/questions/732985/… – rajaganesh87 Oct 11 '17 at 15:48
  • Hmm i already check this. IT dont resolve my problem. I believe have certificates problem. Apt use curl ? – Mickaël OUILLON Oct 11 '17 at 18:32
  • Please include the contents of yarn.list for example, or any other source with failing downloads. – Ferenc Wágner Oct 12 '17 at 5:41
  • Each curl SLL command report : url -L github.com/lsst/lsst_dm_stack_demo/archive/11.0.tar.gz | tar xvzf - % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0 curl: (77) error setting certificate verify locations: CAfile: /etc/ssl/certs/ca-certificates.crt CApath: /etc/ssl/certs/ I know $HOME/.curlrc tip but its not the solution :-/ Cant do it for all my user – Mickaël OUILLON Oct 12 '17 at 22:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.