1

I have a problem with "Kali Linux 2017.2"; I installed it on a USB with live persistence however I cannot connect it to the internet wirelessly for some reason I cannot seem to get it to find the wireless card (bcm4360)

I have tried many methods to try get it to work such as adding the stretch main contrib non-free to my source.List and downloading the headers, common and kbuild deb amd64 files to try and install them manually

Whenever I do iwconfig I receive lo no wireless extensions

I've also run

apt-get update && apt-get upgrade && apt-get dist-upgrade

But still no dice

uname -a : Linux kali 4.12.0-kali1-amd64 #1 smp debian 4.12.6-1kali6 (2017-08-30) x86_64 gnu/linux

lspci -knn | grep Net -A2 : broadcom limited bcm4360 802.11ac wireless network adapter [14e4:43a0] (rev 03)

In my sources list are :

Deb https://http.kali.org/kali kali-rolling main contrib non-free 
Deb-src https://http.kali.org/kali kali-rolling main contrib non-free 
Den http://httpredir.debian.org/debian/ stretch main contrib non-free 
  • @GAD3R all done :) – NanoedStux Oct 11 '17 at 18:10
  • @GAD3R when I run modprobe wl I receive "modprobe: error: ../libmod/libkmod-module.c: 832 kmod_module_insert_module() could not find module by name='wl'" further goes on to say an error running install command for wl and finally could not insert 'wl': I operation not permitted – NanoedStux Oct 11 '17 at 19:34
  • @GAD3R So I can't do anything? – NanoedStux Oct 11 '17 at 19:42
  • @GAD3R i havent been able to figure out how to chroot into the live usb however, i reinstalled the os because something went wrong and it refused to boot, after installing everything i noticed that when i installed the broadcom package it installed wl into a 4.13.0 file path however, the error states it cannot find 4.12.0 as it doesnt exist, does that help at all ? – NanoedStux Oct 12 '17 at 15:00
  • see this tuto nathanpfry.com/how-to-customize-an-ubuntu-installation-disc to create a new iso including the missing package to enable wl module ,at the Add packages to the system you need the broadcom-sta-dkms and the linux-headers once included you can get the wifi working – GAD3R Oct 12 '17 at 15:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.