1

This question already has an answer here:

I cannot login to my Arch Linux machine because the tty keeps getting filled with ^@ characters, and therefore I cannot enter my username or password. What's wrong?

marked as duplicate by Wieland, Stephen Rauch, Hauke Laging, roaima, Jeff Schaller Dec 17 '17 at 22:24

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

migrated from stackoverflow.com Oct 11 '17 at 11:42

This question came from our site for professional and enthusiast programmers.

2

Can you ssh into your machine? If you can, try entering

sudo dmesg -n 1

That will block messages from the kernel. Might not help but worth a try

1

Some protocols use the NUL for keep alives. You could try to set a high keep alive to circumvent this behaviour. E.g. in iTerm2 there is an option called "When idle, sent Ascii code".

0 (null, NUL, \0, ^@), originally intended to be an ignored character, but now used by many programming languages to mark the end of a string.

0

Solved it by running:

rmmod peaq_wmi
rmmod input_polldev

Not the answer you're looking for? Browse other questions tagged or ask your own question.