0

O/S: Raspberry Pi running Raspbian GNU/Linux 8 (jessie)

Kernel: Linux 4.9.24-v7+

Ran ip addr and confirmed wwan0 and wwan1 interfaces are created.

wwan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 1000
link/ether ce:d3:4d:fc:a7:9b brd ff:ff:ff:ff:ff:ff
inet 169.254.160.49/16 brd 169.254.255.255 scope global wwan0
    valid_lft forever preferred_lft forever

wwan1: .....

Successfully started

qmi-network /dev/cdc-wdm0 start

Ran

qmicli -d /dev/cdc-wdm0 --wda-get-data-format

and got result

                        QoS flow header: no
                    Link layer protocol: 'raw-ip'
       Uplink data aggregation protocol: 'disabled'
     Downlink data aggregation protocol: 'disabled'
                          NDP signature: '0'
Downlink data aggregation max datagrams: '0'
     Downlink data aggregation max size: '0'

Ran

qmicli -d /dev/cdc-wdm0 --nas-get-signal-strength

and got result

Current:
     Network 'umts': '-103 dBm'
RSSI:
     Network 'umts': '-103 dBm'
ECIO:
     Network 'umts': -10.0 dBm'
IO: '-106 dBm'
SINR: (8) '9.0 dB'

Ran

dhclient -v wwan0

and got result

Internet Systems Consortium DHCP Client 4.3.1
...

Listening on LPF/wwan0/ce:d3:4d:fc:a7:9b
Sending on   LPF/wwan0/ce:d3:4d:fc:a7:9b
Sending on   Socket/fallback
DHCPDISCOVER on wwan0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on wwan0 to 255.255.255.255 port 67 interval 8
....
....

I tried a lot of times and still cannot get the IP address.

Any help is appreciated.


Edited:

Also, I have tried to change the link layer protocol to 802-3

qmicli -d /dev/cdc-wdm0 --wda-set-data-format=802-3

The message said 'Successfully set data format', but the link layer protocol still is 'raw-ip'.

2
  • Run dhcpcd command
    – GAD3R
    Oct 10, 2017 at 16:38
  • Installed dhcpcd and ran dhcpcd wwan0. Still cannot get the IP address.
    – aobs
    Oct 11, 2017 at 2:27

3 Answers 3

1

dhclient and dhcpcd don't seem to have support for raw-ip. I did however manage to get an IP with udhcpc. It's not available on all Linux distros though, so you're limited to Debian based distros.

0

Couldn't the problem be with the server? Did you try other devices/PCs to make sure they are getting an IP or not? The problem could possibly be with the DHCP server for some reason. Make also sure you are not using a static IP configured on the interface. (I can see you are getting an APIPA address but what is the config in the wwan0.conf for example?

1
  • I can use dhcp to get IP address for my eth0 device. So, it is working fine. I suspect the EM7430 is raw-ip only and dhcp will not work. I need to confirm this.
    – aobs
    Oct 11, 2017 at 8:31
0

Thanks all for your help.

I found out that the EM7430 does not support 802-3 and is raw ip only. It does not work with dhclient nor dhcpcd.

1
  • This is true of the Sierra Wireless EM/MC74 and EM75 series modules, Telit LM940 and LN940 series, and probably others. Looks like wvdial is a path of less resistance than udhcpc for me. Apr 23, 2019 at 6:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.