2

My OS: OS in question, and my primary OS: Debian 9.1 (fresh install) with i3 window manager (no DE). Other OSes (dual booted): Ubuntu 14.04 and Windows 10.

Kernel: 4.9.0-3-amd64

Network cards info: Realtek 8101 ethernet controller which works out-of-the-box (verified many times in Debian 9, Ubuntu, ...) and a Realtek 8723be Wireless network adapter which needs additional tweaking (Installation of a driver patch - due to a fault in the default drivers - tried by myself, it worked fine.).

I installed network-manager-gnome to manage my networks (although ethernet is unmanaged by it since eno1 (my ethernet) appears in /etc/networks/interfaces)

Problem: Network (neither ethernet nor WiFi) doesn't work on fresh reboot. By this I mean that - if I directly boot into Debian and try accessing the internet, it doesn't work. But, if I first boot into say, my Ubuntu, login to the internet there (see Additional info 1 below) and come back to Debian, it works! I have tried this a lot of times and the pattern is always that.

Additional info 1: I am accessing internet from a university campus, so there's a network login page that I must first visit and login. I can't open this login page upon a fresh restart, but if I already login and come to Debian, I can! I find this very strange.

EDIT: There's no proxy server involved. Just a login page.

Additional info 2: There's a known kernel-panic bug associated with my particular Wireless network adapter, network-manager-gnome and Debian. I experienced it as follows: If I don't install that said driver patch for my Wireless adapter, I experience kernel-panic during bootup (sometimes multiple times) and if I do install it, there's no kernel-panic.

To confirm this is indeed the reason for kernel-panic, I checked the syslog at /var/log/syslog and observed something on the lines of wlo1... just prior to the kernel-panic entry.

And please note, with that driver patch I can use my Wireless adapter perfectly fine (provided I login to internet in my Ubuntu for a and come back!).

My question: Why does my network show such a strange pattern, how do I correct it? Any leads would be appreciated. Thanks a lot!

2
  • 1
    Guess: Both Realtek cards need either to download firmware, or need hardware initialization that the Ubuntu kernel + firmware packages provide, while the Debian kernel doesn't and/or has the wrong or no firmware images. Compare dmesg output after boot of both distros to verify this guess.
    – dirkt
    Oct 10 '17 at 6:07
  • Thanks for the response @dirkt. I'll return back in a while.
    – QMrules
    Oct 10 '17 at 18:28
-1

At the bottom of:

https://wiki.debian.org/DualBoot/Windows

It says to add NETDOWN="no" to /etc/default/halt so that linux doesnt 'shutdown' with out the win drivers permission.

1
  • How will that fix the problem described?
    – roaima
    Dec 29 '19 at 23:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.