3

I was playing with configuration files in Debian when after reboot I lost connection to my router.

My NetworkManager says 'no Networks'. When I try and restart the Networking service it hangs and comes back with no errors. It states "Restarting networking(via systemctl): networking.service" and returns 0 after entering in echo $0 after that command.

sudo iwlist wlp3s0 scanning | grep "ESSID:" seems to be working fine outputting:

ESSID:"ASIO Survellance Van 3"
ESSID :"BigPondD7990F"
ESSID:"NETGEAR26"

and so forth...

My /sbin/ifconfig returns an ipv6 address but no ipv4.

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Local Loopback)
        RX packets 3264  bytes 7382182 (7.0 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 3264  bytes 7382182 (7.0 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::a6d1:8cff:fedb:1f6  prefixlen 64  scopeid 0x20<link>
        ether a4:d1:8c:db:01:f6  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

/sbin/iwconfig outputs:

lo        no wireless extensions.

enp0s20u2  no wireless extensions.

wlp3s0 IEEE 802.11 ESSID:off/any 
       Mode:Managed Access Point: Not-Associated 
       Tx-Power=200 dBm 
       Retry short limit:7 RTS thr:off Fragment thr:off 
       Encryption key:off 
       Power Management:off

My external backup Alfa wireless card seems to not be showing in ifconfig -a.

I have tried pinging 8.8.8.8 but it states network unreachable.

cat /etc/network/interfaces outputs

source /etc/network/interfaces.d/*

auto lo
iface lo inet loopback

auto wlp3s0 
iface wlp3s0 inet dhcp

Update: I have installed and loaded the necessary module for bcm4360 wireless interface with modprobe wl but still the same results. Even doing a modprobe -r wl && modprobe wl doesn't work either.

Update: I have done a lsusb | grep "bcm4360" but my wireless nic isn't coming up.

Update: I have access to wired connection via my router with ethernet and usb tethering with my phone.

Update: Output of sudo modprobe -r -v wl && sudo modprobe -v wl:

rmmod wl
rmmod cfg80211
insmod /lib/modules/4.9.0-4-amd64/kernel/net/wireless/cfg80211.ko
insmod /lib/modules/4.9.0-4-amd64/updates/dkms/wl.ko

Please help! If there's anymore information needed please let me know. I'm sure I'm missing something essential.

  • 1
    Please include outputs for commands. In the question, not in comments. E.g. what is the output of "sudo iwlist wlp3s0 scanning"? It seems you are trying to get a wireless collection working. Do you have a wired connection? – Faheem Mitha Oct 8 '17 at 8:27
  • from the terminal run wpa_supplicant -i wlp3s0 -c <(wpa_passphrase Your_SSID your_password) then dhclient wlp3s0 + remove the RJ45 cable – GAD3R Oct 8 '17 at 9:27
2

Someone in the comments who, in my eyes, deleted their comment (which was an excellent answer) stated that problem was a buggy NetworkManager so I inputted sudo apt-get remove network-manager and then sudo apt-get install wicd The new service is not buggy anymore. Thank you for all your comments and help. I wouldn't be able to do it without this community.

  • 2
    To make sur it is not a bug on the wpa_supplicant package , if have proposed to connect through wpa_supplicant before . It is a bug on the network-manager package , please report a bug to debian , Also there are a bug on the wpa_supplicant package but you are not affected, – GAD3R Oct 8 '17 at 9:44
  • I second the recommendation to report a bug, if you think there is one. Also, note that you can accept your own answer if you wish, and it's a good idea to accept an answer if it resolves your question. That way the Stack Exchange machinery will consider that your question has been resolved, and won't drag it to the surface again. – Faheem Mitha Oct 8 '17 at 10:40
  • 2
    I have tried to report the incident to debian with the reportbug program but it seemed to not work. I will probably do it this week depending on how busy I am. – gotoat Oct 8 '17 at 10:58
0

Add allow-hotplug to /etc/network/interfaces to get something like this:

auto wlp3s0
allow-hotplug wlp3s0
iface wlp3s0 inet dhcp

reboot pc and check network connection.

See man interfaces for more information:

Lines beginning with "allow-" are used to identify interfaces that should be brought up automatically by various subsytems. This may be done using a command such as "ifup --allow=hotplug eth0 eth1", which will only bring up eth0 or eth1 if it is listed in an "allow-hotplug" line. Note that "allow-auto" and "auto" are synonyms.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.