0

Not able to find a way to make my touchpad work again. It was working fine in Ubuntu 16.04.3 LTS but when upgraded to RHEL 7.4 it stopped working.

Laptop - Dell Vostro 3468

Things which i tried

  • Verified that it is enabled in Settings > Hardwarde > Touchpad

  • Verified the driver is installed. Both xorg-x11-drv-synaptics and kcm_touchpad.x86_64 are installed and are updated.

  • After reading some of the answers made some changes in 50-synaptics.conf file. I'm keeping this file at both the locations /usr/share/X11/xorg.conf.d and /etc/X11/xorg.conf.d/ as don't know the overriding sequence.

50-synaptics.conf looks like this : -

    Section "InputClass"
    Identifier "touchpad catchall"
    Driver "synaptics"
    Option  "TapButton1"  "1"
    Option  "VertEdgeScroll"  "1"
    Option "RBCornerButton" "3"
    MatchIsTouchpad "on"
    MatchDevicePath "/dev/input/event*"
    EndSection
  • try installing libinput instead of synaptics, another situation could be having external kernel modules altering your driver setup... but first try libinput if that does not work, you need to see which driver is using synaptics in lsmod – Christopher Díaz Riveros Oct 7 '17 at 2:54
0

Following worked for me

1) Add i8042.nopnp to grub command line in /etc/default/grub:

change this:

   GRUB_CMDLINE_LINUX="... quiet"

to:

GRUB_CMDLINE_LINUX="... quiet i8042.nopnp"

2) Update your grub config (as root):

If you're using UEFI boot

grub2-mkconfig -o /boot/efi/EFI/centos/grub.cfg

3) Blacklist module i2c_hid (as root):

echo "blacklist i2c_hid" > /etc/modprobe.d/i2c-hid.conf

4) Regenerate your initramfs (as root):

cp -v /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r).img.bak
dracut -f

5) Reboot!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.