-1

This question already has an answer here:

I have installed Kali Linux on my T100 Transformer Book (laptop). And have not been able to connect to wifi. I am brand new at Kali and don't know much at all about it. Also I have Windows 8.1 but it got deleted in the installation of Kali. So just Kali Installed. No VM. And I have no ethernet port.

Things I have tried:

  1. Going to icon at the top right. It has no WiFi option or anything like it.

  2. ifconfig in terminal shows only lo. And yes I am administrator.

  3. Downloading drivers.

  4. Using an external USB dongle. On other computers it works and lights up green but nothing when I plug it into Kali. Not even the green light. And the USB port works with other devices.

  5. A lot of other things I have tried online. Just commands and things. Nothing works.

Device information:

Laptop - Asus T100 Transformer book
Wireless Protocol - 802.11a/b/g/n
External USB WiFi Dongle - TP-LINK AC1200 Wireless Dual Band USB
Adapter Model: T4U

Edit: I just tried on another external USB wireless dongle and it worked. However, I transport this laptop around all the time and the Dongle is huge.

marked as duplicate by GAD3R, Kusalananda, Stephen Rauch, G-Man, peterh Oct 7 '17 at 17:24

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Honestly it sounds like you shouldn’t be using Kali Linux. Please read Should I use Kali Linux? it is an advanced distribution, not for beginners. If you are unfamiliar with Linux, I would recommend a distribution such as Debian, Ubuntu, or opensuse, which are designed to be desktop distributions, not specifically tailored for penetration testing and advanced users, like Kali. Seems like all Kali Linux questions get downvoted, because you should know what you’re doing. – nullmeta Oct 7 '17 at 2:50
  • But if the other USB dongle worked, maybe you should consider replacing your usb dongle – nullmeta Oct 7 '17 at 2:52
0

Try installing Network Manager with sudo apt install network-manager, and then enable it using systemd by systemctl start NetworkManager.service.

  • The first command worked, the second said nothing (i guess it worked). But still not WiFi option. – Fluke Oct 7 '17 at 2:17
  • sorry, i meant sudo apt install network-manager. – anti4r Oct 7 '17 at 2:20
  • That's with the new command (my first comment) – Fluke Oct 7 '17 at 2:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.