2

In my laptop I have a rtl8723b2 network adapter installed which usally works just fine. I have no problems whatsoever unless I am in a certain room.

In there the wifi sometimes works just fine and other times the network manager says that I am connected to the wifi but I can't access any websites (or anyting else related to the internet).
If I try to open a website it just gets stuck on Looking www.example.com so I thought there might be a problem with the DNS setup but when using ping 8.8.4.4 -c5 it won't get any responses as well.

However the ping command doesn't bail out stating that there is no internet connection. Instead it says that it has sent all packages but received none (reproducable with other IPs as well).

I know for a fact that the wifi signal in that specific room can be kinda problematic but the network manager displays a wifi signal strength of ~ 70% on average which indicates (to me) that this doesn't seem to be an issue.

Purely from the observations (wifi connected but still no internet access) I thought it might have something to do with the powersave-mode of the wifi adapter as described here. Therefore I tried using the fwlps=0 option (I even tried the ips=0 option) but this didn't resolve the problem.

One ting to mention though is that this state of "connected without internet access" can most of the times be resolved by disconnecting from and reconnecting to the wifi network several times or by reloading the respective kernel module via sudo modprobe -r rtl8723be and sudo modrpobe rtl8723be. There are even cases in which the internet access restored itself after a while.

The problem will come up eventually every time I use my laptop in this room. Sometimes it's there directly after booting and sometimes I can surf the internet for a few hours befor it appears.

I have this problem in Linux Mint 18 as well as in Manjaro Linux (which uses the 4.9.52-1-MANJARO kernel).

Does anybody have an idea on what's going on here or even how to fix it?

Note: I also tried plugging in a USB wifi adapter and using that for accessing the internet but the problem did not get solved with that either.

EDIT: My complete "config-file" for the network adapter looks like this:

options rtl8723be fwlps=0 ips=0  ant_sel=1

closed as off-topic by Jeff Schaller, peterh, Stephen Rauch, Anthon, Satō Katsura Oct 16 '17 at 8:00

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, peterh, Stephen Rauch, Anthon, Satō Katsura
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Sry I forgot to mention that I already use the ant_sel=2 option... EDIT: Actually I'm using ant_sel=1 because with 2 it won't even find any wifi network – Raven Oct 6 '17 at 13:18
  • Realtek is not stable; get another brand. unix.stackexchange.com/questions/252210/… – Rui F Ribeiro Oct 6 '17 at 13:58
  • 1
    @GAD3R as Linux Mint 18 uses a different kernel than the current Manjaro Linux I don't think another kernel will solve the problem. Furthermore the problem does only exist in that specific room so in general everything works fine. @F Ribeiro The problem persisted with a wifi USB adapter (though I'd have to check what brand that one is) so changing anything in the laptops hardware is not yet worth the risk – Raven Oct 6 '17 at 14:55
  • 1
    First thing I'd do is a iw wlan0 scan in that particular room, compare it to the results in other rooms, and look for other APs that are either present only in this particular room, or have a strong signal there. – dirkt Oct 8 '17 at 4:41
2

So I found a "solution" to the problem:

It turned out that although my laptop claimed it had a wifi connection strength of ~70% the router saw it a bit differently. It showed that there was barely any connection.

So my thesis is that due to the bad connection there have been some sort of (micro-)disconnects that the network manager did not notice and therefore did not try to fix.

Whatever the reason may have been I solved it by using a wifi repeater so that I have a better signal strength in that particular room and since then the problem did not reoccur.

Not the answer you're looking for? Browse other questions tagged or ask your own question.