0

When I try to use vim's INSERT mode and want to navigate the cursor with the editor yields ^B instead moving the cursor back. Can anybody tell me what I have to rebind to make this work again. Also for .

1

The <C-B> / <C-F> commands only work in normal mode. In insert mode, the literal control characters (rendered as ^B / ^F) get inserted.

You can define mappings that enable scrolling in insert mode:

inoremap <C-b> <C-\><C-o><C-b>
inoremap <C-f> <C-\><C-o><C-f>

The <C-\><C-o> executes a single normal mode command from insert mode.

Alternatively (at least in GVIM), <PageUp> / <PageDown> also work in insert mode out of the box.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.