1

If I disable the journaling function of an EXT4-filesystem using the command tune2fs -O ^has_journal /dev/sda and enable it after the next start, will the data saved on the harddisk remain unaffected or are they lost ? (Ubuntu 16.04 LTS)

  • 1
    Journals are meta-data; are you planning on an orderly reboot (close files, unmount filesystem), or some sort of interrupted-write testing? – Jeff Schaller Oct 6 '17 at 1:02
  • In fact I am trying to spin down my Western Digital harddisks with the program 'hd-idle', which tells me that there still are some read/write access, just a few Kilobytes per minute. But with atop, iotop, htop, iostat etc. I haven't been able to detect the cause. So I thought about disabling the journal, but quite probably I am going to enable it again after the short test. (root device is a ssd, sda and sdb belong to raid1_a, sdc and sdb to raid1_b and raid_a and raid_b form one volume group). – Tim Bremer Oct 6 '17 at 7:33
  • Does hd-idle still show unexplained read and write accesses when your disk is plugged in but unmounted? – dhag Oct 6 '17 at 14:22
  • Yes, it indeed shows r/w-accesses when it is unmounted, so it doesn't look like a journaling issue, but I am running out of ideas what else could be the cause. I also can hear a 'click' sound every ca. 20 seconds, which I can't hear when I am just in the BIOS. smartctl (long test) doesn't show anything special. – Tim Bremer Oct 6 '17 at 19:09
  • Typical output is: root@ubuntu:~# hd-idle -i 0 -a sda -i 300 -a sdb -i 300 -a sdc -i 300 -a sdd -i 300 -d probing sda: reads: 183794, writes: 242 probing sdb: reads: 163945, writes: 242 probing sdc: reads: 146075, writes: 80 probing sdd: reads: 144003, writes: 80 probing sda: reads: 183794, writes: 242 probing sdb: reads: 163945, writes: 242 probing sdc: reads: 146075, writes: 80 probing sdd: reads: 144003, writes: 80 probing sda: reads: 183794, writes: 242 probing sdb: reads: 163945, writes: 242 probing sdc: rea... – Tim Bremer Oct 6 '17 at 19:09
0

As already told tools like atop, iotop, htop, iostat haven't been were helpful. blktrace -d /dev/sda -o - | blkparse -i - showed me that parted, smartctl and one other process (udevd ?) accessed the disc. Strangely enough no config-file had smartctl enabled.... auditd finally helped me to track down the troublemaker, revealing the correlation between the start of smartctl and webmin. webmin checks periodically the temperature of the harddisks, this option can be disabled in Webmin --> Webmin --> Configuration --> Background Status Collection. One should also disable the options Collect system status in background and Collect available package updates.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.