2

I'm currently trying to setup an x86 64bit system to use a Squashfs as its root mountpoint, but i'm being met with many issues. Currently I am using 4.4.0-89 kernel compiled with Squashfs. I am looking to do this on a hard disk, but just for learning and testing sake, I am currently trying to do this from a USB (not sure if this would create issues but I am doubtful).

I have set the device up as so:

Device     Boot    Start      End  Sectors  Size Id Type
/dev/sdb1           2048 14583807 14581760    7G 83 Linux
/dev/sdb2       14583808 15656959  1073152  524M 83 Linux

/dev/sdb1 is a squashfs filesystem of Ubuntu 16.04.3LTS that I created by using

dd if=filesystem.squashfs of=/dev/sdb1

and /dev/sdb2 is boot:

drwxr-xr-x  5 root root     4096 Oct  5 09:57 grub/
-rw-r--r--  1 root root 40177135 Oct  5 09:28 initrd
-rw-r--r--  1 root root  6913440 Oct  4 13:12 vmlinuz

My grub config menuentry is as so:

menuentry 'test' {
        set root=(hd0,msdos2)
        linux /vmlinuz root=/dev/sda1 ro rootfstype=squashfs quiet splash
        initrd /initrd
}

Currently when I try to boot I press escape to get rid of the grub ubuntu splash screen and it runs through the same error lines:

madm: No device listed in conf file were found.
madm: CREATE group disk not found

before finally showing:

Gave up waiting for root device. Common problems:
 - Boot args (cat /proc/cmdline)
   - Check rootdelay= (did the system wait long enough?)
   - Check root= (did the system wait for the right device?)
 - Missing modules (cat /proc/modules; ls /dev)
ALERT! /dev/sda1 does not exist. Dropping to a shell

Where I have access to busybox's shell.

I have tried increasing the rootdelay to 300 which returned the same results as well as using the root partition UUID instead of /dev/sda1 which also did not work.

Within the busybox initramfs shell I cannot even see any sdx in the /dev/ tree.

I may be trying to implement this completely wrong but I am stumped on what to try next so if anyone could help me it would be greatly appreciated!

Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.