I have been using Linux Mint (Cinnamon) for at least a year. Started with 18.1 and once 18.2 was available I did the upgrade to it. Everything has been working perfectly. Yesterday, when I turned on my computer it won't boot. I can see the grub2 menu, the Linux Mint logo being displayed and then I get a white cursor at the top left corner. Nothing else. I tried editing the grub2 load adding the "nomodeset grub_gfxmode=1280x1024x24" but still having the same issue. I was able to get to a command line by doing Ctrl+Alt+F1, able to log in, I ran sudo apt purge "nvidia-*" and then doing startx starts the GUI. But for some reason I have now to do this every time I boot the computer (without the sudo apt purge "nvidia-*").

More information that may help find the root cause and how to fix it:

/etc/X11/default-display-manager says "/usr/sbin/lightdm"

I tried running sudo systemctl start mdm but got error "Failed to start mdm.service: Unit mdm service not found".

Update manager says there is no updates.

Running kernel 4.10.0-35.

Dual booting with Windows 7

I need your help to see what is going on and what made it fail, and hopefully be able to restore it (I have several files/configurations that need to preserve).


Ok, I did: sudo dpkg-reconfigure lightdm and that worked! Don't know what this does, but it fixed my problem. Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.