2

I have a kickstart server that installs Centos 7 without installing NetworkManager. Everything on it works fine, but the networking.

I'm able to get the networking working by logging in via tty1 and running

[root@centos~]# systemctl restart network

Which leads me to believe that it's starting too early.

When it first boots, checking the status of network via systemd shows:

● network.service - LSB: Bring up/down networking


Loaded: loaded (/etc/rc.d/init.d/network; bad; vendor preset: disabled)
   Active: failed (Result: exit-code) since Wed 2017-10-04 07:46:02 PDT; 5min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 1525 ExecStart=/etc/rc.d/init.d/network start (code=exited, status=1/FAILURE)

Oct 04 07:45:55 centos.local systemd[1]: Starting LSB: Bring up/down networking...
Oct 04 07:45:56 centos.local network[1525]: Bringing up loopback interface:  [  OK  ]
Oct 04 07:45:56 centos.local network[1525]: Bringing up interface eno1:
Oct 04 07:46:02 centos.local network[1525]: Determining IP information for eno1... failed; no link present.  Check cable?
Oct 04 07:46:02 centos.local network[1525]: [FAILED]
Oct 04 07:46:02 centos.local systemd[1]: network.service: control process exited, code=exited status=1
Oct 04 07:46:02 centos.local systemd[1]: Failed to start LSB: Bring up/down networking.
Oct 04 07:46:02 centos.local systemd[1]: Unit network.service entered failed state.
Oct 04 07:46:02 centos.local systemd[1]: network.service failed.

I can't seem to find a solution to this specific question, so I'm asking here.

Thanks.

Config file below

#/etc/sysconfig/network-scripts/ifcfg-eno1

NAME="eno1"
DEVICE="eno1"
ONBOOT=yes
NETBOOT=yes
UUID="315e0366-a380-47f2-a9d4-4512a52cdaf2"
IPV6INIT=yes
BOOTPROTO=dhcp
TYPE=Ethernet

EDIT: Setting a static config in /etc/sysconfig/network-scripts/ifcfg-eno1 seems to have resolved the issue.

  • There is an issue with your ifcfg-eno1 file in /etc/sysconfig/network-scripts – Raman Sailopal Oct 4 '17 at 15:01
  • I've updated my post with the config file – ssebs Oct 4 '17 at 15:05
  • And when you execute dmesg | grep "device en" do you see the network interface named eno1 or is it named something else? – Raman Sailopal Oct 4 '17 at 15:17
  • I don't get anything from that. If I execute dmesg | grep "eno1" I can see that: [ 4.181832] systemd-udevd[466]: renamed network interface eth0 to eno1 Could this be the reason? – ssebs Oct 4 '17 at 15:25
  • 1
    Try "ip link show" to see the system names for your interfaces. You may want to put "NM_CONTROLLED=no" in your /etc/sysconfig/network-scripts/ifcfg-eno1 file, too. – docwebhead Oct 4 '17 at 15:39
0

I also encountered similar problems:

enter image description here

To modify the configuration files.(ifcfg-ensxxxx), as follows:

  • Commented out "UUID=xxxx-xxxx"
  • Add new option: NM_CONTROLLED=no #"NM_CONTROLLED=no" indicates that this interface will be set up using this configuration file, instead of being managed by Network Manager service.

Reference: How to configure a static IP address on CentOS 7

  • Screenshots don't like very well on the first spot, I suggest to use copy-paste. Anyways, good answer. :-) – peterh Dec 14 '17 at 8:20
0

Setting a static configuration instead of DHCP seems to have resolved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.