1

How can I configure CUPS not to ask for root password to resume or add a printer? Or add users so they're "administrators"? When using KDE Plasma, it asks for root password: "please enter a username and a password" and it has root in the username field.

3

In Arch Linux at least, the proper place to fix this issue is in the file:

/etc/cups/cups-files.conf

The above file (instead of /etc/cups/cupsd.conf) will contain the SystemGroup setting. (That's probably why @simplegamer couldn't find it in the file mentioned in the other answer here.)

The standard way to resolve this issue in Arch Linux is to:

First add the "sys" group to SystemGroup in /etc/cups/cups-files.conf . Here is an example:

# Administrator user group, used to match @SYSTEM in cupsd.conf policy rules...
# This cannot contain the Group value for security reasons...
SystemGroup sys wheel

Second, add the user to the "sys" group:

gpasswd -a your_username sys

Log out, if logged in as that user for the group change to take effect. After logging in as that user run groups to check that the user belongs to the "sys" group. Now the user should be able to manage printers without being asked for a password.

This approach allows users without sudo rights to be able to manage printers, which is the right approach in my situation. We do not have a root account enabled and we have users who should not have sudo rights, but these users should be able to manage printers / printing.

Beware of solutions suggesting that you "set a root password" in Ubuntu.

printing - "Adding Printer" dialog asks for root password? - Ask Ubuntu https://askubuntu.com/questions/20318/adding-printer-dialog-asks-for-root-password

This is related:

Bug #653132 ""Add Printer” dialog requests root password if user... : Bugs : system-config-printer package : Ubuntu https://bugs.launchpad.net/ubuntu/+source/system-config-printer/+bug/653132

0

Add a group which contains the normal users that should have access to cups administration in /etc/cups/cupsd.conf below the # Administrator user group... line.

SystemGroup sys root users

Then add the normal user's to the group users

Restart the service, and you should be good to go.

systemctl restart cupsd.service
  • users in the configuration and user as the actual group? they have different names, I don't think it would work but I'll try it with the same name – simplegamer Oct 5 '17 at 16:39
  • @simplegamer Sorry a typo I edited it. use users – Hunter.S.Thompson Oct 5 '17 at 16:51
  • There's no # Administrator user group... in my cupsd.conf, so I just added it to the top – simplegamer Oct 5 '17 at 16:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.