3

I'm using Dell Lattitude 5480 and I think that I have a problem with fan speed. For example : CPU gets to the temperature around ~75 C -> fan starts to work as fast as he can Then temp goes down to ~70 and fan's speed starts to vary. Until it's down to ~50 C it vary around 2300 RMP - 2700 RMP (I am monitors fan's speed with sensors ) in very short periods of time. It's quite annoying, is there any way to make this speed constant? I wouldn't thought that its Linux Mint's fault, but on Windows 10 everything works just fine.

  • On the Windows 10 system that you're happy with, can you show us the System Cooling Policy and other Power options? – Mark Plotnick Oct 2 '17 at 21:07
  • Fan speed is generally not intended to be constant; higher temperature readings cause the fans to work harder in order to dissipate more heat. – DopeGhoti Oct 2 '17 at 21:23
  • Would you mind telling me how to find 'System Cooling Policy' ? I rarely use Windows and have no idea where to look for it. – ogarogar Oct 3 '17 at 12:27
  • The issue is that in 1 seconds in can be changed from quick to slow, I know that when its 60 C and you want your CPU at 50 C u dont have to use 1000% of fan power, but when in 1 second it can vary from (for example) 40% to 60% its quite annoying. – ogarogar Oct 3 '17 at 12:29
1

Try installing fancontrol package and use sudo pwmconfig

there is a tutorial to change fan settings here : Control fan speed Youtube video

Edit 1:

According the video you first install lm-sensors and fancontrol using sudo apt install

Then you do sudo pwmconfig and you put y answering the questions. After that you put the path of the file e.g /home/**Your user name**/Desktop/fancontrol Then you will get something like this: selection of config

select 1 which is the controller of the fan and insert the values according to the following image:

last steps

Then you copy the code generated in the file on desktop open the terminal and use this command: sudo nano /etc/fancontrol

Finally paste what you copied and press cntl+x to save and exit. Now you can run sudo fancontrol

  • Please import the relevant details from the youtube video to your answer, otherwise it's ... not much of an answer. – Jeff Schaller Mar 1 '18 at 18:33
  • I have edited the answer and added the details of the youtube video. – Ahmed K Moustafa Mar 1 '18 at 20:22
0

Check to see if there is something stressing your cpu (or gpu) when this happens. It could be chrome or slack. Remember that the CPU can instantly go from 50 C to 90 C under heavy load. The system temperature takes a little while to catch up.

Usually there are fan settings in the BIOS that allow you to change the fan speed characteristics, but YMMV.

Found an answer for Ubuntu to use fancontrol - https://askubuntu.com/questions/22108/how-to-control-fan-speed

  • I will try it, I used i8kutils but sadly when i use sudo i8kfan 2 2 I get the same issue with fan. It's slow-fast-slow-fast and it changes quickly and thats what I wan't to get rid off. I think that BIOS can be the issue, but then why Windows can handle it? – ogarogar Oct 3 '17 at 12:33
  • Sadly when i write sudo pwmconfig my fan start working only for really short period of time so th test won't pass and it makes using fancontrol impossible. – ogarogar Oct 3 '17 at 13:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.