0

I have a problem with a new 8 TB (internal) hard drive, used for storing and process large amount of data downloaded from FTP servers. I checked the disk with GSmartControl and everything seemed to be alright, so I started using it.

The problem is that each time data are downloading into the disk, after storing ~200 to 600 Gb, the disk is stopping working. Any attempt to write into it, failed (I had messages of the type "read-only filesystem").

I tried to remount the disk as read-write and it was impossible (I had the message

"cannot remount block device UUID=aee6675e-52bf-4e09-9435-fcba67f13b3d read-write, is write-protected") 

When I tried a file system check I got this:

fsck.ext4: Attempt to read block from filesystem resulted in short read while trying to open /dev/sdb1 Could this be a zero-length partition?

At /var/log/messages I saw messages like this

Sep 18 20:07:40 vega kernel: [274385.736369] sd:0:0:0:  00 08 0 I/O erro5.736386] EXT4-fs error (device sdb1): __ext4_get_inode_loc:3740: inode #1972742humbnail: unable to read itable block
Sep 18 20:07:40 vega kernel: [274385.7d 1:0:0<6>[2743e=DID_BA274385.736470] sd 1:0:0:0: [sdb] CDB: Read(10): 28 00 22 40 0e 08 00 00 08 00I/O error, dev sdb, sector 574623240
Sep 18 20:07:40 vega kernel: [274385.736479] sd 1:0:0:0: [sdb] Unhandled error code
Sep 18 20:07:40 vega kernel: [274385.736481] sd 1:0:0:0: [sdb]  Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK
Sep 18 20:07:40 vega kernel: [274385.736483] sd 1:0:0:0: [sdb] CDB: Read(10): 28 00 22 40 0e 10 00 00 08 00

The problem is solved only after rebooting the computer. At the moment and since I temporally stopped the data downloading, the disc seems to be fully functional. In addition, both filesystem check and smart control are not detecting any type of issue/problem.​

Besides this situation being annoying, I am wondering if it is an indication that the disk is faulty.

  • What model of HDD is it? Is it based on SMR (Shingled Magnetic Recording)? – Jaroslav Kucera Oct 2 '17 at 18:51
  • It is a Seagate Archive HDD v2 8TB, SATA 6Gb/s. Yes it is based on SMR. – Marios K. Oct 2 '17 at 19:12
0

I'm afraid, the described behaviour is "feature" of archive disks based on SMR. The disk has some part of its capacity in normal format (in your case probably those 600 GB). This area serves as cache for writing. But the problem is, that data in SMR disks must be written at once in quite big area. Usualy the size of such area is 256 MB. And even if you change single byte, complete 256 MB area must be rewritten again.

So if you fill the cache buffer completely, the disk must first write the data into SMR form, which takes much longer time...

So SMR disks are really more usable for archiving with reading from time to time, than for write load operations...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.