I've got a USB key i'm having trouble mounting on a Raspberry Pi running Raspbian.

When I attach it I can see it as /dev/sdb1, type=exfat, it's got a label and a name. But when I try and mount it I get:

FUSE exfat 1.1.0
ERROR: unknown entry type 0xc5

What are my next steps to mount this key or confirm it's faulty?

1 Answer 1


Came across this question while looking for my own mysterious ERROR: unknown entry type 0xc1 running FUSE exfat 1.2.7 which I could not really solve yet.

In my case everything seemed to work fine (AFAIK) until I mounted the exFAT-volume on a windows (8.1) system for the first time which mounted it without any complaint but showed an empty filesystem (no entries) but with some considerable space (about 66% which was about the amount of data copied onto it before on a linux machine) miraculously occupied.

I also found an issue on GH revolving around unknown entry type 0x96 which started to let me think that the hex-code itself (0xc5, 0x96 or 0xc1) is of minor importance, but something (not necessary the same) underlying went possibly wrong.

from the discussion on GH I learned that the following commands might help to get a clearer picture what might be going on (make sure to specify the correct device!):

  • dumpexfat /dev/sdb1
  • mount.exfat-fuse -d /dev/sdb1
  • exfatfsck /dev/sdb1

In my case, all these commands exited with the exact same error-message described above.

Also in the issue it is recommended to upgrade if running v1.1.0 as you are so that might already help in your case.

I yet have to take a closer look at what may have caused the corruption in my case as I have a suspicion that it might be related to the way I formatted the filesystem (mkfs.exfat with individual volume-ID and name)...

EDIT: was able to reproduce what I wrote above. Certain characters in custom volume-names seem to cause the behaviour I observed. Issue #89 openend on GH ...

EDIT2: FUSE exfat 1.2.8 seems to successfully fix Issue #89 so I'd recommend to upgrade to that version (or newer once released in the future...).

  • I had experienced this same issue on my Linux laptop mounting a exfat formatted SD card from my Sony Xperia Android phone. I have found that after a recent update (early August 2018), android's formatting of the SD card now mounts on my Linux machine. The only thing that changed was my android update at which time I tried re-formatting the same SD card. I'm running community/exfat-utils 1.2.7-1 on my Arch linux machine. Aug 12, 2018 at 20:15

You must log in to answer this question.