0

Linux Mint 18 doesn't show all Windows computers under 'browse network'. How do I tell Thunar (and other desktop network applications) to try the SMB2 protocol?

Background

I installed Linux Mint 17 on a laptop, used it awhile, and then allowed Update Manager to upgrade Mint 18. In v17 I was able to browse to Windows computers on the network and access the file shares on several machines. After upgrading to v18 I can only see 1 computer on the network.

During the upgrade I was asked a few times if I wanted to keep my local version of config files or use the package maintainer's. I said to use maintainers. I don't remember which programs these referred to.

In Thunar file manager Browse Network shows the machine I can still access "DESKTOP-XXX" and "Windows Network". After opening Windows Network I see two workgroup icons - "HOME" and "WORKGROUP". The computers I can't see anymore belong to HOME while the one I can access is in WORKGROUP.

In Terminal smbtree reports same as Thunar:

matt@dell-xps ~ $ smbtree
Enter matt's password: 
WORKGROUP
    \\DESKTOP-XXX       
HOME

Smbclient -L \server throws an error:

matt@dell-xps ~ $ smbclient -L \\server
WARNING: The "syslog" option is deprecated
Enter matt's password: 
protocol negotiation failed: ERRDOS:ERRnomem

Thanks to @Ping_Squiddy in https://superuser.com/questions/857324/connecting-with-smbclient-to-windows-7-produces-error-protocol-negotiation-fai/ I learn that -m SMB2 (and/or SMB3) lets me in the door:

matt@dell-xps ~ $ smbclient -L \\server -m SMB2
WARNING: The "syslog" option is deprecated
Enter matt's password: 
Domain=[SERVER] OS=[] Server=[]

    Sharename       Type      Comment
    ---------       ----      -------
    ADMIN$          Disk      Remote Admin
    C$              Disk      Default share
    ...snip...
    print$          Disk      Printer Drivers
Domain=[SERVER] OS=[] Server=[]

    Server               Comment
    ---------            -------

    Workgroup            Master
    ---------            -------

How do I tell Thunar (and other desktop network applications) to try the SMB2 protocol?

Update:

Perhaps a small step in right direction: from https://askubuntu.com/questions/919967/how-to-tell-gigolo-gvfs-to-use-smbv2-for-windows-shares I learn that "editing /etc/samba/smb.conf and adding the following to the [global] section: client max protocol = SMB3" allows smbclient to list shares without specifying the protocol level.

However this has the side effect of not showing any Workgroups at all in 'Browser Network', and also in smbtree. And, unfortunately smb:///server/ in Thunar shows zero results too.

1

Apparently in Mint 18.2 some samba server components were left out. Installing samba as per "Installing Samba Server in Mint 18" got workgroups to show up in Thunar again.Also helpful is "HowTo: Samba Browsing Problems Checklist".

Now I can browse the SMB1 workgroup (named 'WORKGROUP' in the Q) and see their list of shares and access the files. I get an error when browsing the SMB2 workgroup ('HOME'), but if I type the full path I see the folders and files and can then use create shortcut for later use.

The key part for my system was sudo apt-get install samba --install-recommends. I didn't need to do the other part about firewalls.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.