0

I am running Mint 18.2 Sonya and using the nvidia-375 drivers.

The game in question is Crusader Kings II. From within the steam client it launches fine. However, I would prefer not to use the client if at all possible. I know this is possible with the Win version of CK2 by simply running the executable directly. Running the executable ~/.steam/steam/steamapps/common/Crusader\ Kings\ II/ck2 from Thunar results in nothing, so I ran it via command-line instead and got this message:

./ck2: error while loading shared libraries: libuuid.so.1: cannot open shared object file: No such file or directory

A little searching tells me this is a missing lib file. I found libuuid.so.1 in /lib/x86_64-linux-gnu/ and made a symlink from there to /usr/lib/

This was a fix I found from someone with a similar issue: same game, different missing lib. Running the executable from command line again nets a new error.

./ck2: error while loading shared libraries: libuuid.so.1: wrong ELF class: ELFCLASS64

More research shows that this means the lib that I symlinked is the wrong architecture. Which I really should have expected since I found the thing in /lib/x86_64-blah-blah. However now I cannot seem to find a 32-bit version of libuuid.so, I even tried symlinking it to /usr/lib32 instead, but then it goes back to complaining that the library is missing. I checked to make sure my multiarch-support package is up to date, as well.

Edit: I made sure the libuuid1 package was up to date. Here is the dpkg -L results:

/.
/usr
/usr/share
/usr/share/doc
/usr/share/doc/libuuid1
/usr/share/doc/libuuid1/changelog.Debian.gz
/usr/share/doc/libuuid1/copyright
/lib
/lib/x86_64-linux-gnu
/lib/x86_64-linux-gnu/libuuid.so.1.3.0
/lib/x86_64-linux-gnu/libuuid.so.1

1 Answer 1

0
 export LD_LIBRARY_PATH=/usr/lib32:$LD_LIBRARY_PATH

This will make sure steam will look first in /usr/lib32 to find the needed libraries.

This fix worked for some users.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .