0

I'm trying to mount at boot a HFS+ core partition in Linux Ubuntu. I followed some other questions here and I came up with this mount command, which seems to properly work, providing read/write access to the partition:

sudo mount -t hfsplus -o force,rw,sizelimit=$((935960064*512)) /dev/sda2 mount

Now I would like it to be mounted at boot as usual, so I'm trying to add the proper line to /etc/fstab. This is what I wrote:

UUID=0e1ad81d-63b6-35cd-93f0-ea8cfbadaefe       /mnt/480GB1     hfsplus force,rw,sizelimit=479582773248 0       0

where:

sudo blkid /dev/sda2
/dev/sda2: UUID="0e1ad81d-63b6-35cd-93f0-ea8cfbadaefe" TYPE="hfsplus" PARTLABEL="480GB1" PARTUUID="276b2d0a-193a-4325-a1aa-09dd84516b4e"

but this is the answer:

sudo mount -a
mount: wrong fs type, bad option, bad superblock on /dev/loop0,
       missing codepage or helper program, or other error

       In some cases useful info is found in syslog - try
       dmesg | tail or so.

dmesg returns:

[10292.068918] hfsplus: invalid secondary volume header
[10292.068922] hfsplus: unable to find HFS+ superblock

Any idea what I'm doing wrong?

1
  • The mount error message looks suspicious: "bad superblock on /dev/loop0". Are you sure the errors are related to the line you added to /etc/fstab? Sep 30, 2017 at 14:29

1 Answer 1

0

Your sizelimit is not identical. Could this be the cause?

2
  • Woh! Good catch! Last time I wrote the line I wrote it properly but I copy-pasted a wrong similar number. It works properly now. Don't know why someone downvoted you. Sep 30, 2017 at 16:51
  • Well, because there are a lot of people on SE who believe they are "right" and the others should piss off.
    – JPT
    Sep 30, 2017 at 17:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.