3

I downloaded the Debian amd64 netinstall ISO and placed it on a USB stick using dd if=debianblahblah.iso of=/dev/sdb. The installer works fine, but my laptop requires proprietary wireless drivers (RTL8192) to get internet during the install.

I extracted the drivers from the realtek folder in the firmware-nonfree package. I wanted to put them in the /firmware folder on the install disk, but the it's not writable. So (following various instructions found online) I then tried to create a second partition in the remaining space on the drive (partitioned/formatted as VFAT), and move the files there. But I can't mount the partition, and receive error "mount: wrong fs type, bad option, bad superblock on /dev/sdc3, missing codepage or helper program, or other error" if I try to mount the new partition.

I also tried placing the files on a separate USB, but the Debian installer couldn't find/detect them (and unfortunately, the installer isn't designed to give any info on why it failed).

How do I include the rtlwifi drivers on the same disk as the debian ISO so that the installer can find them? Or alternately, how do I make a 2nd USB disk that the installer can recognize?

  • Can you add the message displayed by the installer? – GAD3R Sep 30 '17 at 9:07
  • There is no error message displayed by the installer. During the "Detect Network Hardware" portion of the install, it tells me I need the Realtek firmware, and asks me to insert removable media with the files. When I do this, and select Yes -> Continue, it pauses for a moment and then returns back to the same screen with no information about what happened. – J. Taylor Sep 30 '17 at 9:56
  • You can skip the installation of the missing firmware then install it later (the fastest way). or using the unofficial images which include the non-free firm – GAD3R Sep 30 '17 at 9:58
  • The installation of the missing firmware from a FAT usb is also possible if you get the exact name of the missing binary. Loading Missing Firmware – GAD3R Sep 30 '17 at 10:01
  • Thanks, I understand that I can install without internet connection and then install the firmware later, but I'd like to figure out how to get it to actually work during installation and detect the firmware files like it's supposed to. I'm assuming they wouldn't have included the firmware dialog in the installer if there wasn't a way to make it work. I'm specifically looking for info on how to either (a) create an install disk with the firmware on it or (b) create an install disk and a separate USB disk with the firmware on it that is detectable by installer. – J. Taylor Sep 30 '17 at 16:43
1

I experienced the same with wifi drivers (firmware-iwlwifi) which weren't automatically recognized although being located in the root directory of the USB device.

I've found a working solution here.

In short:

  • Download the Debian firmware package corresponding to your hardware
  • Open the data archive inside it and put the content of lib/firmware/ into the root directory of your FAT USB device
  • Insert the USB device if the installer asks for it, switch via Ctrl+Alt+F2 to a virtual terminal and mount your device to /lib/firmware/, e.g. by using mount /dev/sdc1 /lib/firmware

That's it. The installer should find the firmware and probe the corresponding device during network setup.

After the installation has finished and your new system has booted you have to do roughly the same to be able to use the device immediately. Create /lib/firmware/ and copy the files into this directory. Reboot and your device will appear. Now install the corresponding firmware Debian package via your package manager.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.