I wanted to Download a large (1GB) File from our Server via SFTP. I have a 400Mbit Cable Connection which under Windows gives me ~32Mbyte/s download Speed with WinSCP from my Windows Machine.

If it try to download that file on my Mint Box via SFTP, it stays @ 10Mbyte/s. If i try to download the Same File via HTTP i get my full bandwidth.

The Two Computers are connected to the same switch, with the same connection to the cable modem router. They have the same ping and on iperf also almost the same rates. They are both more than capable of handling these transfer Speeds, I am not talking Raspberry Pi, but newest Intel Core i5.

The Throtteling must be with Linux (Mint Sonya) somehow. I tried to search IPTables, or tc for any rule which might do that, but i found none. Also i am not an expert on IPTables and linux built in QOS.

I need to find the Bottleneck here? I want to download files at full speed with SFTP.


1 Answer 1


The original poster provided this solution:

I found the Solution by accident.

I am sure I am not the only one suffering from this limiting behavior of the Linux Kernel in Mint. So i decided to post the Solution here:

It looks like the Kernel TCP Memory Settings are not optimized for "high speed" Internet Connections. And a "laymen" like me searches for "SFTP Throtteling" or "Linux SFTP Download Limited" and gets no answer to this Problem et all. When in fact, this is what happens.

So i found a TCP tuning website which has TCP Kernel Tuning options (from 2003):


These effect the Send and Receive Memory consumption for the TCP Protocol. This Site has some old values and i adapted these Values to fit my needs.

You can set these in /etc/sysctl.conf, reboot and enjoy full sftp speed with more then 10MByte/s even with the values presented on the site. My guess is, that SFTP would need more memory for reaching full speed then HTTP.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .