0

I used to be able to dual boot Windows 10 and Ubuntu, but I wanted to change to Debian. So I deleted the /dev/sda5 and /dev/sda6 partitions that were used by Ubuntu. This did not remove grub2, so I deleted grub from Windows (I used this guide: http://linuxbsdos.com/2015/09/05/how-to-delete-grub-files-from-a-boot-efi-partition-in-windows-10/). The problem is that now I can't install any linux distro in the unallocated space that was created. I have tried openSUSE, Debian and Ubuntu. The installers ran with no errors, but when I rebooted it booted straight to Windows 10. I went into msconfig and the only Operating System that is listed there is Windows. The /dev/sda5 and /dev/sda6 partitions that were created are full, but grub is not even available as a boot option. I have tried:

  1. Running boot-repair from Ubuntu
  2. Changing the partition scheme and target system type
  3. Using different usb sticks and tools (Rufus and UUI)
  4. Changing the boot order, enabling safe boot, disabling fast boot etc.`
  5. Enabling boot logging from msconfig
  6. Re-installing grub

What else can I do?

2

Have you tried just installing GRUB?

Boot into a live cd's rescue mode after installation and run these commands:

update-grub
grub-install -v <Disc name>

And then reboot, you should have GRUB greet you!

Also, check your BIOS, maybe you are booting into the wrong disc?

0

I found the solution: I had to run bcdedit /set {bootmgr} path \EFI\<name_of_distro>\grubx64.efi. Replace with "debian", "ubuntu" etc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.