1

I am trying to upgrade Linux Mint 17.3 Rosa Cinnamon edition to the latest Linux Mint 18.2 Sonya.

But after the mintupgrade check, I get the following errors:

The following packages have unmet dependencies:
 adwaita-icon-theme : Breaks: gnome-themes-standard-data (< 3.18.0-2~) but 3.10.0-1ubuntu2 is to be installed
                      Breaks: gnome-themes-standard-data:i386 (< 3.18.0-2~)
 adwaita-icon-theme-full : Breaks: gnome-themes-standard-data (< 3.13.90) but 3.10.0-1ubuntu2 is to be installed
                           Breaks: gnome-themes-standard-data:i386 (< 3.13.90)
 metacity-common : Breaks: gnome-themes-standard-data (< 3.15.90) but 3.10.0-1ubuntu2 is to be installed
                   Breaks: gnome-themes-standard-data:i386 (< 3.15.90)
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Internal error, Upgrade broke stuff

tried uninstalling "gnome-themes-standard-data" and redoing the update process .. but the error still persist.

Searched but..No good answers in the internet yet, Do not ask me to do a fresh install , that's not my question and I refrain from it because I have made the system to this shape after months of effort.

  • Editors Attention ..!!! : Do not change the Question title please it need to address the specific issue "adwaita-icon-theme : Breaks: gnome-themes-standard-data" – Clain Dsilva Sep 28 '17 at 4:41
  • @Vlastimil the system is up to date and dpkg --get-selections | grep hold did not return anything [empty] – Clain Dsilva Sep 28 '17 at 6:29
  • Why down vote? Down voters ..!! have manners to explain why? – Clain Dsilva Sep 28 '17 at 6:33
  • I have listed the terminal output here pastebin.com/iG0BfK4x – Clain Dsilva Sep 28 '17 at 11:21
0

In response to the PasteBin outputs:

You have a lot of additional repositories and PPAs, all of which you need to manually remove before doing the major upgrade.

Without that, who knows what will happen. Nothing good, that's for sure.

Please install ppa-purge package:

sudo apt-get install ppa-purge

And proceed with the removal with maximum caution and remove all of the additional repositories just by moving the files elsewhere from /etc/apt/sources.list.d/.

An example follows:

sudo ppa-purge ppa:whatever/ppa

More importantly, you need to downgrade all packages to trusty or rosa if it is specific package used by Mint.

The Linux Mint 17.x is based on Ubuntu 14.04 Trusty, so for example:

sudo apt-get install adwaita-icon-theme/trusty

or

sudo apt-get install adwaita-icon-theme/trusty-updates

or

sudo apt-get install adwaita-icon-theme/rosa

The commands are ordered by success rate from the highest, but I recommend to try it in this order:

  1. rosa

  2. trusty-updates

  3. trusty

It's a lot of work, I realize that, but I myself have done it and successfully.

Reasoning: Most probably one of the PPA or additional repository upgraded adwaita-icon-theme and other packages. The underlying reason being that you would de facto have newer version already installed of some packages which causes dependency issues. Hope my answer helps a little

EDIT1:

In response to the comment of non-existend package:

there is no such package named adwaita-icon-theme

There is adwaita-icon-theme and the others in Ubuntu Xenial which is the base for Linux Mint 18.x.

In response to the comment of restoring PPAs:

if I purge all PPA and fail how can I restore them?

Simply edit the PPA source files located in:

/etc/apt/sources.list.d/

And remove the # beginning character.


You can try installing the apt-show-versions:

sudo apt-get install apt-show-versions

The usage is simple, call the program and grep results you are interested in.

It could, with some effort, resolve your problem with identifying the packages to downgrade. As I said, you need to downgrade all packages prior to proceeding with major system upgrade, so if you have already removed the PPAs and other repositories, now go ahead and downgrade what you can to trusty as mentioned above.

If you have multiple computers, then it's very simple to set-up SSH. Why SSH? Well, no upgrade with a lot of system adjustments goes smoothly and rather than being stuck at the console, I mean VT1, and typing all from your head, when things go south (and they most probably will), it's much more convenient to sit at another computer and communicate with the world for instance about what the hell happened.

I personally would go ahead with the upgrade right now, ignoring the problem, and I would solve it via SSH from another machine later when it happens. I have managed to convert KDE to Cinnamon editions and upgrade them later, it can't be harder than that. I think it will be a piece of cake, at best you'll learn a few usable commands, and at worst you restore your drive from backup.

BACKUP:

One way to make a totally perfect backup of your drive is:

  1. Boot from a live USB with Linux Mint.

  2. Install pv utility:

    sudo apt-get install pv
    
  3. If you have multiple drives, make sure you find out witch one is the one with your Linux Mint 17:

    sudo fdisk -l
    
  4. Suppose you have one system drive and one external HDD for the backup /dev/sda, then it would be as simple as clicking on the external HDD in Nemo, that will mount the drive and then:

    sudo -i
    pv < /dev/sda > /media/username/drivename/backup-sda-pv
    
  • Thanks much for your help, But can you give me any pointers on what causes this error? in that case we can specifically install / remove the thing that causes error – Clain Dsilva Sep 28 '17 at 12:08
  • even I was thinking the same, but amazingly there is no such package named 'adwaita-icon-theme' I tried removing it and the system said there is nothing like that. Also if I purge all PPA and fail how can I restore them? – Clain Dsilva Sep 29 '17 at 3:17
  • @ClainDsilva see edit, hope it helps – LinuxSecurityFreak Sep 29 '17 at 5:32
0

@Vlastimil thanks for your extended help and guidelines ...

I was able to fix the bug by removing gnome-themes-standard-data

sudo apt remove gnome-themes-standard-data

This did the trick, the error says that it will break my version of gnome-themes-standard-data if adwaita-icon-theme is installed ...

Hence the cluprint was my version of gnome-themes-standard-data.

Performed an update sudo apt update and upgraded linux mint even though there was a series of troubles ... it ultimatly upgaded to Sarah and from there I upgraded to Sonya.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.