2

Installed Ubuntu twice and Linux Mint once onto an SSD that used to be a system disk after Ubuntu was corrupted in upgrade.

Every time, I get the same result. When I try to boot from the disk, I get a black screen with a cursor, and nothing loads.

I am able to get something to load when I choose "Boot from first hard disk" in a live CD.

However, this drops me to Busybox, and doesn't load all of the commands. I cannot fsck, for instance. A simple exit crashes the system so that ALT + CTRL + Delete won't restart.

I tried the solutions here, trying to use an alternate superblock. I don't think it applies because the disk appears to be otherwise usable.

fsck -b returns clean and I've tried at least 3 superblocks with Ubuntu and Linux Mint installs. I don't think that's the issue.

I've also tried adding root=/dev/sdc1 to my grub to pass on to the kernel, as outlined here. At least, I added them to my grub parameters and updated grub via a live CD using this method. Perhaps this was wrong but it was all I have been able to find before this point.

So far, no dice. The machine isn't even printing different errors.

Is it possible that the SSD isn't bootable anymore, despite being able to read/write and reporting clean from a fsck?

If not, how can I fix it?

errors from initramfs/busybox

  • Boot from the rescue and choose do not mount the files systems , from the shell run fsck with -f option on your root partition – GAD3R Sep 28 '17 at 18:58
  • I might be confused. Rescue from Live Disk? I can't even get to the GRUB menu on the SSD to select Recovery Mode. I can only get to the above screen with the "Boot from first disk" option on the Live Disk. – ezgoodnight Sep 28 '17 at 19:04
  • the recovery mode from the advanced options of grub nenu – GAD3R Sep 28 '17 at 19:06
  • Yes, I can't access that. The disk doesn't boot on its own (black screen with cursor, described above), and the "boot from first disk" option gives me the above output. – ezgoodnight Sep 28 '17 at 19:08
  • 1
    I was very cautious about modifying the disk full well knowing it was clean and ok. It turned out to be a corrupted frub2 config. Strange that it "looked fine" but doing an grubupdate worked once I was CHROOTed – noybman Apr 23 '18 at 3:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.