1

I'm trying to install Linux Mint xfce x86 on an old laptop that I have in my possession, but I keep getting an error when trying to boot into Live CD; it says:

[sdb] No Caching mode page found

[sdb] Assuming drive cache: write through

And then it's just stuck there. The USB that I'm trying to install it off of does work (tried it on my Core 2 Duo machine) and it boots perfectly fine.

It doesn't work in compatibility mode, it just spits out a black screen after what looks like initialization of the live CD.

6
  • What is your graphic card model?
    – GAD3R
    Commented Sep 27, 2017 at 17:11
  • It's a GeForce 9300M GS
    – Tekunikaru
    Commented Sep 27, 2017 at 17:17
  • 1
    Try to boot with nouveau.blacklist=1 and acpi=off parametres
    – GAD3R
    Commented Sep 27, 2017 at 17:20
  • 1
    see KernelBootParameters , past nouveau.blacklist=1 acpi=off before quiet splash
    – GAD3R
    Commented Sep 27, 2017 at 17:22
  • Doesnt seem to work, pnp 00:0c: unknown tag 0x0 length 0, pnp 00:0c: unknown tag 0x1 length 4, pnp 00:0c: no end tag in resource structure
    – Tekunikaru
    Commented Sep 27, 2017 at 17:30

3 Answers 3

1

In my experience the usb_live_boot disk booted fine on my newer laptop but wouldn't boot on a slightly older laptop.

The fix for me was to remove persistent from the boot string. So it was just casper quiet splash.

My 2¢.

0

Boot linux mint with nouveau.blacklist=1 nolapic parameters (see KernelBootParameters )

to permanently add the parameters after installing the system ,edit your /etc/default/grub change the line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet"

To

GRUB_CMDLINE_LINUX_DEFAULT="nouveau.blacklist=1 nolapic quiet"

And update grub:

sudo update-grub
9
  • a little thing here, i keep getting 'failed to get canonical path of aufs' when running sudo update-grub, the only fix i found reinstalls grub and thus resetting the grub file, any possible fix to this?
    – Tekunikaru
    Commented Sep 27, 2017 at 18:44
  • follow this answer , unix.stackexchange.com/a/96981/153195 , use sudo grub-install --root-directory=/mnt /dev/sdX , instead of sudo grub-install /dev/sdX . sdX is your hdd , also replace sda6 with your root partition
    – GAD3R
    Commented Sep 27, 2017 at 18:53
  • @Tekunikaru are you solved your problem?
    – GAD3R
    Commented Sep 28, 2017 at 13:58
  • That doesnt seem to work either, running sudo updat-grub outputs sudo: unable to resolve host mint: Connection refused and /usr/sbin/grub-probe: error: cannot find a device for / (is /dev mounted?)., when running that grub install command you gave me it outputs sudo: unable to resolve hostname mint: Connection refused, grub-probe: error: cannot find a device for /boot (is /dev mounted?)., Installing for i386-pc platform and grub-install.real: error: cannot find a device for /mnt/boot/grub (is /dev mounted?)., whats going on here?
    – Tekunikaru
    Commented Sep 28, 2017 at 14:03
  • Remove the kernel parametre and try to boot without it , just keep GRUB_CMDLINE_LINUX_DEFAULT="quiet" then run sudo update-grub and reboot.
    – GAD3R
    Commented Sep 28, 2017 at 14:06
0

I had this issue as well, but underneath it was actually a problem with graphics drivers. I added nomodeset to boot options and booted successfully. For more information see https://askubuntu.com/questions/947830/errors-from-nouveau-when-installing-or-booting-from-live-usb

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .